Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am having the same problem as this guy where a fresh Ubuntu install completes beautifully but will not boot.

I get the ASUS (?) "Reboot and select proper boot device" error, first with Xubuntu 13.10 and after finally giving up there, and Xubuntu 13.4, I am back to regular Ubuntu 13.4. ASUS motherboard Z77, Intel chipset. Standard internal SATA 500GB HD. 64-bit. All-new hardware less than 3 months old. It was running Ubuntu 12.04LTC great until I tried this upgrade.

I have re-installed from scratch every which way: with LVM, without LVM; with the default partitions, with my own partitions. With ext3 or ext4. Alongside; replace; upgrade. No difference. On the last two tries, I have booted afterward from the same USB stick, downloaded and run boot-repair, and now I guess I am off to the boot-repair support email with my URLs from that. It did all kinds of cool stuff but ultimately made no difference.

I never got anything like this with Ubuntu 12.04. I've now probably re-installed Ubuntu 13.04 ten times slightly different ways. I finally found how to skip the language packs, so at least that sped things up! :)

This starts from the ubuntu-13.04-desktop-amd64.iso and UNetbootin as suggested on the official instructions for USB thumb drive creation from OSX. That part all works fine (booting the USB on the PC and trying Ubuntu and/or installing from there on the PC HD.) I have no CD drive on this PC, but I suppose I could get one. I would rather find some Linux install that works from USB like I've always done.

After running boot-repair twice, in the ASUS BIOS I now see three different UEFI boot options in the priority list, and they are all labeled exactly the same:

ubuntu (P6: WDC WD5000AAKX-00U6AA0)

Then there's a non-UEFI option:

P6: WDC WD5000AAKX-00U6AA0 (476940MB)

And a fifth option appeared after the first boot-repair:

Windows Boot Manager (P6: WDC WD5000AAKX-00U6AA0)

I have tried all 5 of these, and I get exactly the same error.

I have never had Windows installed on this HD. ASUS is calling it Windows Boot Manaer but I presume that's a mistaken label for whatever boot-repair did.

I can boot on USB and run GParted and it looks great. The partitions all look normal.

I found another case of this online with no solution posted. I can't find much about it online. Needs a Master Boot Record wipe/redo?? I'm not sure how.

share|improve this question
    
I flashed the system BIOS and that made no difference. I also did some random hardware troubleshooting: removed and re-seated RAM, moved the drive to a different SATA port, unplugged and redid all connections, etc. Did another fresh install. No change. Going to hunt some other distro incl. maybe back to 12.04. –  IcarusNM Jun 5 '13 at 18:46
add comment

1 Answer 1

Solution: Update the ASUS BIOS with a newer version.

The great support team at Boot-Repair concluded this was a UEFI bug with my BIOS. I did update the BIOS near the end of all this, so apparently that did something good.

I also seemed to have better luck generating the installation USB from within Ubuntu itself rather than from a Mac using UNetbootin, but that may not have anything to do with it.

Good luck!

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.