Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 10.04. I got an error when using update-manager to update.

enter image description here

share|improve this question

closed as too localized by jrg, Jacob Johan Edwards, htorque, ajmitch, Nathan Osman Jan 27 '12 at 2:32

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
could you translate what it say the error output. and please include with your question. thanks –  Achu Mar 15 '11 at 5:57
    
It's also too small to read, for those who could. So, yes, if you can reproduce some part of the error text, it will help. –  belacqua Mar 15 '11 at 5:59
    
Hey Buddy. If you want quick turn around time please post screen shots in English. Most of us can't read your language :( –  Abhijeet Mar 15 '11 at 6:21
    
@Tom: Not being rude, but it is advisable to post screenshots in English. Even I am not a native english speaker, but have to communicate in English over the internet so that I am able to reach maximum audience. –  Manish Sinha Mar 15 '11 at 10:14
1  
Can you post the output of LANG=en_US.utf8 sudo dpkg --configure -a? –  arrange Mar 15 '11 at 10:26

1 Answer 1

EDIT:

Try this instead:

Close all package management, press ALT+F2 and type:

sudo cp /var/lib/dpkg/status /var/log/dpkg/status.old

This will create a backup file. Then:

gksudo gedit /var/lib/dpkg/status

This will open Gedit.

screenshot

Search the package that causes the problem and delete its entry, make sure you leave a blank line between the entries after you delete.

Now open Synaptic and reinstall the package or remove it if you are sure you don't want it.

share|improve this answer
    
I have done that,nothing changed. –  Tom Mar 16 '11 at 3:34
    
How about using the commandline to update? sudo apt-get update && sudo apt-get upgrade –  Reda Lazri Mar 16 '11 at 9:36
    
I have tried that approach.I got the same result. –  Tom Mar 17 '11 at 5:18
    
I updated the answer, please take a look. –  Reda Lazri Mar 18 '11 at 9:40

Not the answer you're looking for? Browse other questions tagged or ask your own question.