Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I was playing around with

apt-get install source --compile 

And I used audacity:

sudo apt-get install source --compile audacity

However, I am getting a dependency error:

dpkg-checkbuilddeps: Unmet build dependencies: autoconf automake debhelper (>= 7.0.50~) libasound2-dev libavcodec-dev (>= 4:0.6) libavformat-dev (>= 4:0.6) libavutil-dev (>= 4:0.6) libexpat1-dev libflac++-dev libgtk2.0-dev libid3tag0-dev libjack-dev libmad0-dev (>= 0.14.2b) libmp3lame-dev libogg-dev (>= 1.0.0) libportsmf-dev libsbsms-dev (>= 2.0.0) libsndfile1-dev (>= 1.0.0) libsoundtouch-dev (>= 1.3.1-2) libsoxr-dev (>= 0.0.5) libtwolame-dev (>= 0.3.9) libvorbis-dev (>= 1.0.0-3) libwxgtk2.8-dev portaudio19-dev (>= 19+svn20101113-3~) vamp-plugin-sdk (>= 2.0)    
dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)
Build command 'cd audacity-2.0.3 && dpkg-buildpackage -b -uc' failed.
E: Child process failed

Unmet build dependencies Makes me believe dpkg is the one with missing dependencies, but I'm really not sure. Installing audacity with

sudo apt-get install audacity 

Works just fine, so I don't think this is audacity's issue.

I've seen this question: How do I resolve unmet dependencies?, but I'm not sure if that applies to this or not.

share|improve this question

closed as too localized by Seth, fossfreedom Jun 7 '13 at 20:27

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I assume that you attempted to install the packages listed under "Unmet build dependencies" (autoconf, automake, debhelper, etc), right? –  InkBlend Jun 5 '13 at 4:02
    
@InkBlend Yeah, I tried that and it fixed the problem. Personally I think this was a stupid question. Lets close as too localized. –  Seth Jun 7 '13 at 17:57
add comment

1 Answer 1

Build-time dependencies are separate from compile-time dependencies, so you can install them with apt-get build-dep audacity.

However as this installs otherwise unnecessary packages, it's common to set up pbuilder, e.g. as explained on http://askubuntu.com/a/39718/129

share|improve this answer
    
Well installing the packages manually solved the problem. I'm not sure I quite understand your answer though. Could you elaborate some? –  Seth Jun 6 '13 at 2:42
1  
'apt-get build-dep' automates that step of installing the packages manually, but there are other tools like pbuilder or sbuild to further automate & isolate the package building process. –  ajmitch Jun 6 '13 at 4:07
    
@ajmitch And what packages are expected to be installed using this command? –  Lucio Jun 7 '13 at 18:12
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.