Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The data sheet for the IOGear Universal Wi-Fi N Adapter states that it supports Linux (Fedora 10 (Kernel: 2.6.27.5-117)) but has no directions in the manual.

When setting up the static IP address using the xfce network connections GUI:

enter image description here

page 33 of the manual gives these directions (for Mac):

Select your Ethernet connection in the left pane. Next change configure to Manual and enter IP address 192.168.1.100 and Subnet Mask 255.255.255.0. Remove any entries in the Router and DNS boxes then click Apply.

Should the default gateway be 0.0.0.0? Or, should it be the ip address for the router (in this case, 192.168.0.1) from which the adapter obtains its internet connection? My reading of the wikipedia page on default gateway suggests yes, but I'm not sure.

Or, should it be the IP address for the adapter itself?

share|improve this question
add comment

2 Answers

A key step is to power-cycle the adapter (yes, I had to resort to reading the fine manual). (Also, I reset the adapter.)

After copying interfaces.static to interfaces I then ran service networking restart and navigated firefox to 192.168.1.252 (as previous) and configured the wireless (SSID and password).

The key step is to then powercycle the adapter. Then, change back to dhcp and restart the networking.

thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ ll
total 44
drwxr-xr-x   6 root root  4096 Jun  4 18:42 ./
drwxr-xr-x 166 root root 12288 Jun  9 14:58 ../
drwxr-xr-x   2 root root  4096 May 13 00:59 if-down.d/
drwxr-xr-x   2 root root  4096 May 13 00:50 if-post-down.d/
drwxr-xr-x   2 root root  4096 May 12 21:00 if-pre-up.d/
drwxr-xr-x   2 root root  4096 May 13 01:01 if-up.d/
-rw-r--r--   1 root root   268 Jun  9 15:08 interfaces
-rw-r--r--   1 root root   268 Jun  4 18:42 interfaces.dhcp
-rw-r--r--   1 root root   336 Jun  6 21:26 interfaces.static
lrwxrwxrwx   1 root root    12 May 12 20:17 run -> /run/network/
thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ nl interfaces.static 
     1  # This file describes the network interfaces available on your system
     2  # and how to activate them. For more information, see interfaces(5).

     3  # The loopback network interface
     4  auto lo
     5  iface lo inet loopback

     6  # The primary network interface
     7  auto eth1
     8  iface eth1 inet static
     9  address 192.168.1.100
    10  netmask 255.255.255.0
    11  gateway 192.168.1.252
thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ nl interfaces.dhcp 
     1  # This file describes the network interfaces available on your system
     2  # and how to activate them. For more information, see interfaces(5).

     3  # The loopback network interface
     4  auto lo
     5  iface lo inet loopback

     6  # The primary network interface
     7  auto eth1
     8  iface eth1 inet dhcp
thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ ping 192.168.1.252
PING 192.168.1.252 (192.168.1.252) 56(84) bytes of data.
^C
--- 192.168.1.252 ping statistics ---
7 packets transmitted, 0 received, 100% packet loss, time 6048ms

thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ ping ie100.net
PING ie100.net (61.147.105.17) 56(84) bytes of data.
64 bytes from 61.147.105.17: icmp_req=1 ttl=112 time=176 ms
64 bytes from 61.147.105.17: icmp_req=2 ttl=112 time=178 ms
64 bytes from 61.147.105.17: icmp_req=3 ttl=112 time=184 ms
64 bytes from 61.147.105.17: icmp_req=4 ttl=112 time=176 ms
64 bytes from 61.147.105.17: icmp_req=5 ttl=112 time=177 ms
64 bytes from 61.147.105.17: icmp_req=6 ttl=112 time=176 ms
^C
--- ie100.net ping statistics ---
6 packets transmitted, 6 received, 0% packet loss, time 5005ms
rtt min/avg/max/mdev = 176.565/178.483/184.375/2.757 ms
thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
default         192.168.0.1     0.0.0.0         UG    0      0        0 eth1
link-local      *               255.255.0.0     U     1000   0        0 eth1
192.168.0.0     *               255.255.255.0   U     0      0        0 eth1
thufir@dur:/etc/network$ 
thufir@dur:/etc/network$ 

What's unclear to me is why I'm not able to ping the adapter. The adapter is at 192.168.1.252 but I can't seem to ping it. In fact, I don't understand why I had to change from static to dhcp, nor powercycle the router. Perhaps the router only accepts pings from certain IP addresses, and when the computer connects with DHCP it doesn't get assigned that magical IP address?

I think resetting the adapter and powercycling it "fixed" the problem. Just don't see why I had to do that.

share|improve this answer
    
isn't that odd. The static ip address is 192.168.1.x while the dhcp ip address is 192.168.0.x --- perhaps this was throwing me. –  Thufir Jun 9 '13 at 22:24
add comment

The Gateway should be the IP of the Router, that giving the connection to the Internet. Setting it to 0.0.0.0, won't get you anywhere. One way of finding out your gateway, is using a system that already connected to the internet, and just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command(s) below:

route

This the output: enter image description here

To add the default gateway, you can use the GUI utility that you have in your question, or from terminal. (in your case)

sudo ip route add default via 192.168.0.1
share|improve this answer
    
Just to add to this and to point out one thing to @Thufir: since your router is 192.168.0.1, then your adapter's static IP should be set to 192.168.0.100, not 192.168.1.100 like what the guide says. –  Alaa Jun 5 '13 at 5:00
    
see my answer below. When an IP address is acquired using DHCP, the adapter gives out an address in the 192.168.0.x range. However, to connect to the adpater, to configure it, a static ip address of 192.168.1.100 is used. Very odd. (the fine manual gives different IP address for Mac OS versus Windows XP as well, so depending upon your OS a different IP address should be used.) –  Thufir Jun 9 '13 at 22:27
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.