Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

First, I installed Ubuntu 13.04.

I have an ATI Radeon HD 7850.

The open source drivers allowed multiple displays, but were horrendously laggy (even opening a browser window took several seconds). When I installed the Catalyst proprietary drivers, performance was perfect. The only problem is that trying to enable dual-monitors in the Catalyst center was grayed out and in the Ubuntu settings resulted in the resolution error.

Is there any way around this?


Here is the quote from the error box when trying to change display settings.

The selected configuration for displays could not be applied

required virtual size does not fit available size: requested=(3840, 1080), minimum=(320, 200), maximum=(1920, 1920)

Here is the grayed out option in Catalyst...

enter image description here

share|improve this question
    
Can you show screenshots of the grayed out Catalyst Center option and the resolution error in Ubuntu's settings? –  Leo Jun 4 '13 at 19:21

1 Answer 1

Just a quick sanity check, but that setting requires root... Did you open as root (w/like 'sudo amdcccle')? If not, this is required in order to change that setting.

Though if you didn't there is usually a pop-up that states "To make changes on this page Administrator access is required...." This pop-up has a check box "Do not show me this again". Given your "grayed out" symptoms, this seems like it would be the issue, and the do not show me again option may have been previously selected...

In ubuntu-gnome 13.04 (hate that name, as it is now an official distro, it should be Gnubuntu, following the alternate DE naming convention), a launcher is created for AMD CCC and AMD CCC (Administrative) but I couldn't get the latter to work until I installed gksu (which 13.04 excludes by default).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.