Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using juju against HP Cloud and the instance shows built and I can ping it fine but the juju status is showing it's still pending and it's not coming up in a browser. Any ideas on what could cause this and how I can diagnose what's going on?

machines:
   "0":
     agent-state: started
     agent-version: 1.11.0
    dns-name: 15.185.97.43
    instance-id: "1569389"
     series: precise
   "1":
     instance-id: pending
     series: precise
     services:
   juju-gui:
     charm: cs:precise/juju-gui-61
     exposed: true
     units:
       juju-gui/0:
         agent-state: pending
         machine: "1"
share|improve this question
    
I made some more machines and they all show pending an the instance-state shows "missing" so obviously I set something up wrong :( –  Joel Brandenburg Jun 4 '13 at 18:51
add comment

1 Answer 1

The current version of juju, 1.16.3 addresses a lot of the issues in 1.11.0 - if you haven't already tear down this install with juju destroy-environment, upgrade juju, then attempt to bootstrap again.

If that doesn't work, check your HP account if you have instances actually spun up. If not, consider destroying the environment again then juju bootstrap --show-log --debug to identify what's going on.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.