Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded to 13.04 2 days ago, wireless worked fine.

Then I got some updates the next day, installed all.

Now I cannot connect to my WPA2 secured network. Smart-phones, tablets and windows 7 (I use dual boot on my laptop) work perfect.

Is that somehow related with BCM4313 802.11b/g/n Wireless LAN Controller? If yes, how to proceed?

Edit: adding the output of sudo lshw -C network:

*-network               
       description: Wireless interface
       product: BCM4313 802.11b/g/n Wireless LAN Controller
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:12:00.0
       logical name: eth1
       version: 01
       serial: c0:f8:da:5c:8c:86
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=wl0 driverversion=6.20.155.1 (r326264) latency=0 multicast=yes wireless=IEEE 802.11abg
       resources: irq:17 memory:fbb00000-fbb03fff
  *-network
       description: Ethernet interface
       product: AR8152 v2.0 Fast Ethernet
       vendor: Qualcomm Atheros
       physical id: 0
       bus info: pci@0000:13:00.0
       logical name: eth0
       version: c1
       serial: f0:4d:a2:d8:cc:36
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress vpd bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=atl1c driverversion=1.0.1.1-NAPI latency=0 link=no multicast=yes port=twisted pair
       resources: irq:48 memory:fba00000-fba3ffff ioport:e000(size=128)
share|improve this question

closed as off-topic by Seth Dec 14 '15 at 2:55

This question appears to be off-topic. The users who voted to close gave this specific reason:

If this question can be reworded to fit the rules in the help center, please edit the question.

    
Add the output from the following command sudo lshw -C network to your question – Warren Hill Jun 4 '13 at 15:39
    
Take a look at this answer, and scroll down to the section of "Special Cases (BCM4313". – Alaa Ali Jun 4 '13 at 15:40
    
editing the original post with the output @WarrenHill. I'll also read this answer, Alaa. Thanks for the feedback :) – Nooboss Jun 4 '13 at 22:42
    
this didn't worked for me @Alaa – Nooboss Jun 5 '13 at 13:40
    
Wait, is this problem due to my Broadcom driver? I noticed i use Atheros on windows and works fine, should i install an linux version of Atheros too? – Nooboss Jun 5 '13 at 14:36