Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

What I have and a map of the speakers:

The Model: HP Envy 15 3040nr

What this does not show is that there are actually 4 speakers in the front so in summary there are 6.1 speakers:

  • two on the front left
  • two on the front right
  • two above the keyboard
  • a sub on the bottom the laptop

The Problem:

Audio only comes out of the front, and I'm not sure if it's all four or two of the four.

I can't figure out what to do software wise, being a complete noob to Ubuntu/linux, but I got that Alsa thing if anybody wants to take a crack at it.

share|improve this question
The "Playback Channel Map" devices in the script output look interesting. Try running alsamixer from terminal, look if you can change something in there related to channel modes. Also have a look into audio system settings and probably kill PulseAudio with pulseaudio -k and wait for it to respwan (you can see it in the indicator). – LiveWireBT Jun 4 '13 at 7:19
BTW, Maintenance and Service Guide also shows that this model has only 4.1. Having a huge mesh where the speaker is supposed to be doesn't imply a huge speaker or multiple speakers behind the mesh.… – LiveWireBT Jun 4 '13 at 7:36
Well I tried everything you said to no avail.... I also tried this… but the config file does not save. Oh and the official HP guide says 4 in the front (bottom of page ten) but they might function as single units... – theyoungest1 Jun 5 '13 at 3:31
hda-jack-retask is new to me I only know about HDA Analyzer which doesn't look that userfriendly. Have you tried pulseaudio -k after chaning the configuration with hda-jack-retask to let PA respawn and probably find the right configuration? – LiveWireBT Jun 5 '13 at 8:16
One user was able to get the subwoofer working… – LiveWireBT Jun 5 '13 at 8:34

I have a HP Envy dv7-7390eb laptop and in Ubuntu 14.04.1 (fresh install) what worked for me was:

gksudo gedit /etc/pulse/

and add the following line

load-module module-combine channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe

When you reboot and go into sound settings (click on volume control icon and choose "sound settings") an extra entry "Simultaneaous output to Built-in Analog Stereo" appears in the "Output" tab. Click on this, then click on the "Test sound" button to the right and you will now have 6 speakers to test. For me 5 out of 6 work now, only subwoofer remains silent. Which is a big step forward, albeit not a full solution...

(Everything I tried relating to changes in /etc/modprobe.d/alsa-base.conf, like adding the line options snd-hda-intel model=ref or variations on this, did not work. And I try to keep away from hda-jack-retask because it seems a bit dangerous to a noob like me).

share|improve this answer
Great that you found a way to make yours work. Do they all work independently? Have you tried channels=8 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe,side-le‌​ft,side-right to make the subwoofer work? – LiveWireBT Aug 3 '14 at 9:19
@LiveWireBT: channels=8 etc. didn't work for me: on reboot I had no sound at all and no usable sound interface in sound settings. – Bart Aug 6 '14 at 12:28

I managed to have all the channels (hdajackretask only has center and LFE, all the other ones are mute, at least in ubuntu 14.10 with me) So I followed this tip:

gksudo gedit /etc/pulse/

and add the following line:

load-module module-combine channels=6 channel_map=front-left,front-right,rear-left,rear-right,front-center,lfe

There's something else needed for the subwoofer

enable-lfe-remixing = yes
default-sample-channels = 5
default-channel-map = front-left,front-right,rear-left,rear-right,lfe

to /etc/pulse/daemon.conf.

All 6 channels work. Volume seems low though. Cheers

share|improve this answer

The reddit post you refer to should indeed work, but if ~/.pulse doesn't exist, you need to create it, and then remove it after you apply changes in hda-jack-retask.

Note: For 13.10, it's now part of alsa-tools-gui, so after installing that, you can just run hdajackretask

More info on that here:

To make life easier while testing on 13.10, I just used the following:

ln -s .config/pulse .pulse && hdajackretask && rm .pulse && pulseaudio -k && pulseaudio -D  

Mine is setup just as the reddit post.

(I would have just commented, but I don't have enough rep. :S ).

I'm on an HP ENVY TS 15 J053cl, and sound testing with the below doesn't give me rear speakers, but they're playing audio, so guessing just as internal. (Setting them as back doesn't do any good).

I tested via:

speaker-test -c5 -l1 -twav  

I'll play with it some more when I have time, but wanted to post to hopefully help others..

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.