Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

Right this is pretty much my own fault, I was trying to get steam to work and I had already tried all the experimental drivers so I decided to start from the beginning; I installed the first nvidia driver from the additional drivers menu. Ubuntu does not load.

If I launch from recovery mode the computer tells me that the drivers will not load until I reboot, and I get to log in through what appears to be a full screen terminal. I can ctrl-alt-f1 and ctrl-alt-f2 through and create different log ins.

I was wondering if someone could guide me through the process of uninstalling and installing a working driver from here, that is only IF that is the problem and I missed something completely.

I am running 12.04 on a acer aspire 6935 laptop, if more information is needed please ask away.

Thank you!

share|improve this question
add comment

marked as duplicate by Uri Herrera, user68186, Kevin Bowen, belacqua, psusi Jun 5 '13 at 13:53

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

2 Answers

up vote 0 down vote accepted
  • Login in one of those terminals
  • Issue dpkg --get-selections | grep nvidia: you should get there the name of the package providing nVidia driver. It should be something like nvidia-current, nvidia-experimental, etc.
  • Remove it using sudo apt-get remove <package-name>

Now reboot and check if it works again. If not try to move xorg.conf:

sudo mv /etc/X11/xorg.conf /etc/X11/xorg.conf.backup
share|improve this answer
    
Thank you I tried the first three bullet points then, typed sudo reboot, twice I think there were some stuff the computer wanted to do first and it WORKED. I am now running Ubuntu normally on what appears to be the driver I was running before thank you. –  Jonathan Jun 3 '13 at 19:24
add comment

press ctrl-alt-f1 and log in to the command line run "dpkg -l | grep nvidia" to find the package name of the driver run "sudo apt-get remove YOURDRIVER" (replace with the name of your driver) run "sudo reboot" you should be back to the stock driver

share|improve this answer
    
I am sorry that I did not get to read your comment before trying the above answer. The answers appear to be the same, and I would to inform you that it worked so thank you! –  Jonathan Jun 3 '13 at 19:25
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.