Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I successfully installed GNOME 3 and GNOME Shell from the Launchpad PPA on my fully updated Natty test system. However, nothing I tried could get it to actually run.

If I selected it in the startup options, I got a plain light blue screen with absolutely nothing on it.

If I tried to start it using gnome-shell --replace, I got:

gnome-shell --replace &
[2] 3251
tim@nattytest:/usr/lib$ Traceback (most recent call last):
  File "/usr/bin/gnome-shell", line 705, in <module>
    normal_exit = run_shell()
  File "/usr/bin/gnome-shell", line 293, in run_shell
    if shell is None:
UnboundLocalError: local variable 'shell' referenced before assignment
/usr/bin/compiz (core) - Error: Screen 0 on display ":0.0" already has a window manager; try using the --replace option to replace the current window manager.

[2]+  Exit 1                  gnome-shell --replace

I also tried preceding that with metacity --replace, as suggested at ubuntuforums.com. But, I got the same failure.

I also linked /usr/lib/libmozjs.so to /usr/lib/xulrunner-2.0b12/libmozjs.so, which did not help either. No matter what I try, I get the same error messages.

share|improve this question

closed as too localized by Marco Ceppi Dec 3 '11 at 12:50

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
IMO, you're lucky you're just having difficulty running gnome-shell. Every time I tried installing from that PPA (gnome3-team), it bricked my install completely and I couldn't get it working again, even after running PPA-purge and manually downgrading the packages. –  Jon Mar 19 '11 at 5:43
    
I am having the same problem... so I am resorting to trying to compile it using the instructions at: askubuntu.com/questions/22946/… –  Valorin Mar 20 '11 at 6:34

3 Answers 3

Try installing xulrunner-2.0 manually and try invoking gnome-shell. That worked for me. [Edit] I am not sure if I noticed the fact that you tried creating a link to xulrunner. I identified my problem using pdb (python debugger). If you are familiar with it, give it a shot. I added these lines before the line where the error was thrown:

import pdb
pdb.set_trace()

Then basically walked through the code until I found that one of the dependencies (xulrunner) in my case was not installed. So I installed the missing dependency using synaptic. The problem may be that it requires a very specific version.

Hope this helps.

share|improve this answer

I just recently installed Gnome3 from gnome3-team and one of the sites I visited (can't remember which) advised the removal of unity and overlay-scrollbars from your system before running gnome-shell. Supposedly Unity and Gnome3 misbehave when running concurrently on a single installation.

If you have access to your system with either Unity or Ubuntu Classic, run Synaptic and remove all instance of both unity and overlay-scrollbars from your computer (removing Unity will add other packages including Unity-2d). The first time I ran gnome-shell I got a system error and was force logged-out to the GDM. But the second attempt was successful and saw no errors afterwards.

Kubuntu is my main system for everyday use and I installed Ubuntu on a separate partition was a test system to try out Gnome3. The only thing I know so far is that gnome-shell boots up properly; I don't know how stable it is for everyday use.

share|improve this answer

To start Gnome Shell, select your username in the login screen as you normally do to login. Next, click the arrow at the bottom of the screen where it says "Ubuntu Desktop" and instead select "Ubuntu Gnome Shell Desktop". Now enter your password and you'll be in Gnome Shell.

To return to Unity, select "Ubuntu Desktop" when you login. You can also try out "Ubuntu Classic Desktop" to get a desktop similar to previous Ubuntu releases.

Please do not set Gnome Shell in your Startup Options. You also shouldn't need to do anything with xulrunner.

share|improve this answer
    
jbicha, thanks for your answer, but as I said in the original question, when I do it that way, all I get is a blank light blue screen with absolutely nothing on it. –  Tim Mar 16 '11 at 14:19

Not the answer you're looking for? Browse other questions tagged or ask your own question.