Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a [Dell Inspiron][1] 15R 5520 laptop. Bluetooth is not working at all.

rfkill list all gives

0: hci0: Bluetooth

    Soft blocked: no
    Hard blocked: no

1: phy0: Wireless LAN

    Soft blocked: no
    Hard blocked: no

2: brcmwl-0: Wireless LAN

    Soft blocked: no
    Hard blocked: no

dmesg|grep -i bluetooth gives

[   13.644428] Bluetooth: Core ver 2.16
[   13.644445] Bluetooth: HCI device and connection manager initialized
[   13.644453] Bluetooth: HCI socket layer initialized
[   13.644455] Bluetooth: L2CAP socket layer initialized
[   13.644461] Bluetooth: SCO socket layer initialized
[   15.861363] Bluetooth: hci0 command 0x1003 tx timeout
[   15.903443] Bluetooth: can't load firmware, may not work correctly
[   17.332535] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[   17.332538] Bluetooth: BNEP filters: protocol multicast
[   17.332544] Bluetooth: BNEP socket layer initialized
[   17.393768] Bluetooth: RFCOMM TTY layer initialized
[   17.393781] Bluetooth: RFCOMM socket layer initialized
[   17.393783] Bluetooth: RFCOMM ver 1.11

hciconfig gives

hci0:   Type: BR/EDR  Bus: USB
    BD Address: E0:06:E6:D5:DB:46  ACL MTU: 1021:8  SCO MTU: 64:1
    RX bytes:687 acl:0 sco:0 events:56 errors:0
    TX bytes:2024 acl:0 sco:0 commands:52 errors:0

I have visited the site and according to it

lspci -vnn -d 14e4: gives

08:00.0 Network controller [0280]: Broadcom Corporation BCM43142 802.11b/g/n [14e4:4365]
 (rev 01)
    Subsystem: Dell Wireless 1704 802.11n + BT 4.0 [1028:0016]
    Flags: bus master, fast devsel, latency 0, IRQ 17
    Memory at c1500000 (64-bit, non-prefetchable) [size=32K]
    Capabilities: <access denied>    
    Kernel driver in use: wl

So I got my PCI-ID as 14e4:4365 which it says is not supported. The alternative is wl.

What should I do?

My Wi-Fi is working normally without any problems, but Bluetooth is not working.

sudo dpkg -i wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb gives following error 
(Reading database ... 208543 files and directories currently installed.)
Unpacking wireless-bcm43142-dkms (from wireless-bcm43142-dkms_6.20.55.19-1_amd64.deb) ...
Setting up wireless-bcm43142-dkms ( ...
Loading new wireless-bcm43142- DKMS files...
Building only for 3.8.0-23-generic
Building initial module for 3.8.0-23-generic
Traceback (most recent call last):
  File "/usr/share/apport/package-hooks/", line 22, in <module>
    import apport
ImportError: No module named apport
Error! Bad return status for module build on kernel: 3.8.0-23-generic (x86_64)
Consult /var/lib/dkms/wireless-bcm43142/ for more information.
share|improve this question
Possible duplicate of Bluetooth Broadcom 43142 isn't working on ubuntu 15.04 – Pilot6 Oct 2 '15 at 11:17

Could it be that your laptop's bluetooth device is attached to USB, not PCI bus? Try lsusb and see if it comes up. E.g. (on my machine):

$ lsusb
Bus 001 Device 005: ID 0a5c:21e6 Broadcom Corp. BCM20702 Bluetooth 4.0 [ThinkPad]

You should also update BIOS first, if you have any hardware detection problems.

This will probably come as off-topic here, but I'll briefly describe how I managed to update BIOS on a Dell laptop:

  • download FreeDOS pre-built ISO image and use it to make a bootable USB drive;
  • download BIOS update from Dell support site, make sure you get the version that will run under DOS
  • boot into FreeDOS and run the BIOS update.
share|improve this answer

This bluetooth chip is not supported by kernel drivers. To get it work. it is better to report a bug at launchpad. It needs to be added to btusb driver and also you will need to convert and add firmware for that. Anyway it it can't be solved here.

share|improve this answer

Have you try this, and type in the terminal this:

 sudo apt-get install dkms
 sudo apt-get install blueman
 sudo dpkg-reconfigure Bluetooth

and it might work fine this way.

share|improve this answer

For a 64-bit Ubuntu installation, you can[1]:

Even more answers are in the Ask Ubuntu question Lost WiFi after 12.10 upgrade.

1. From the official Ubuntu forum, Broadcom BCM43142 Driver Ubuntu 12.10 64 Bit.

share|improve this answer
i did the three steps above and they worked without any problem but still bluetooth is not working – chanzerre Jun 3 '13 at 19:35
This has nothing to do with bluetooth problem – Pilot6 May 11 '15 at 16:56

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.