Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently took the step, formatting my main drive and installing Ubuntu 12.04 LTS in place of Windows 7. I'm not too much of a stranger to Linux I use it frequently in work, but this one has me stumped.

In the course of setting everything up, I installed VMWare Workstation 9. However, when I tried to turn on my first imported VM, it gave an error:

Unable to change virtual machine power state: Cannot find a valid peer process to connect to

I wanted to eliminate the possibility of an incompatibility, so I set up a brand new VM with a different OS but got the same error. Playing around with the settings yielded a different error:

Unable to change virtual machine power state: Failed to power on '(VM name)'. Transport (VMDB) error -14: Pipe connection has been broken.

I have played around with the VMX file and Googled extensively, also tried removing all the virtual hardware I could without any luck, I am simply unable to power on any VM's.

I looked through the questions and answers relating to this problem on this site and tried the suggestions, most of them did not apply, and none of them described accurately the problem I am experiencing.

Any idea what could be causing this?

share|improve this question
    
I recently had this problem. I solved it by rebooting my laptop =/. If that does not work, have you stumbled upon this? You'll need to delete a few files, besides editing the .vmx file (as you probably did). –  Alaa Jun 3 '13 at 15:09
    
I have rebooted several times. And I tried that, too... Of course, it doesn't apply to a brand new VM, but I tried it on the old one. –  kkhugs Jun 3 '13 at 15:24
    
I'm getting this problem intermittantly with vmware 10 on Ubuntu 3.10. In my case, the VMs start, but then get disconnected from vmware workstation within a minute or so...and produce the same error messaging until I manually kill the VMX. –  HDave Oct 22 '13 at 13:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.