Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm using a 64bit Windows 8 inside vmplayer, with 2 virtual processor cores, virtual hard disk resides on a fast local disc and is not preallocated; host CPU is Intel i7 3770, should be capable of hardware virtualisation but I don't know if VMWare uses it; NAT networking; Sound card connected, USB connected, accelerated 3D graphics (NVidia 313.30 on host)

My problem is, that the VM often pauses for a few seconds, and then speeds up for a few seconds to reach real time again. Time in the VM actually moves faster after the pause, for example all animations using timers speed up.

When running, the vmware-vmx process shows ~150% CPU usage in top, but 0% when pausing (and D state i.e. waiting for IO). iotop shows normal disk writes from vmware-vmx threads, but during pauses, the flush kernel thread uses 99%.

Are there some options to try so that VMWare doesn't wait for IO? I've tried a few things available from the GUI but the issue never went away…

share|improve this question
add comment

1 Answer 1

In my case, this was happening because a floppy drive was connected to the VM even though the host had no access to one. Once I "Disconnected" it from the VM from the "Removable Devices" dropdown, the issue went away. This was a Windows 8 host with VMWare 9 running Ubuntu. It also happened for a windows guest.

share|improve this answer
    
I don't have a virtual floppy, but a physical partition as another virtual disk, this sounds similar, I'll try disconnecting it… (it feels like disconnecting the sound card helps a bit, too) –  pascal Jun 29 '13 at 0:00
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.