Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Whhile installing free radius protobuf package I am getting following error

root@ggns2egl01:/tmp/rlm_protobuf-freeradius-2.1.x# ./configure
checking for gcc... gcc
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables...
checking whether we are cross compiling... no
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking for ranlib... ranlib
checking for a BSD-compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether make sets $(MAKE)... yes
checking for curl-config... no
*** The curl-config script could not be found. Make sure it is
*** in your path, and that curl is properly installed.
*** Or see http://curl.haxx.se/
configure: error: Library requirements (curl) not met.

I installed curl package but getting same error

my Machine details are as follows

root@ggns2egl01:/tmp/rlm_protobuf-freeradius-2.1.x# uname -a
Linux ggns2egl01 3.2.0-23-generic #36-Ubuntu SMP Tue Apr 10 20:39:51 UTC 2012 x86_64  x86_64 x86_64 GNU/Linux

I also tried to install packages which have curl-config command but those packages have lots of dependency.

root@ggns2egl01:/tmp/rlm_protobuf-freeradius-2.1.x# curl-config
The program 'curl-config' can be found in the following packages:
* libcurl4-gnutls-dev
* libcurl4-nss-dev
* libcurl4-openssl-dev

root@ggns2egl01:/tmp/rlm_protobuf-freeradius-2.1.x# apt-get install libcurl4-gnutls-dev
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
curl : Depends: libc6 (>= 2.17) but 2.15-0ubuntu10.2 is to be installed
libc6-dev : Depends: libc6 (= 2.15-0ubuntu10) but 2.15-0ubuntu10.2 is to be installed
libcurl3 : Depends: libc6 (>= 2.17) but 2.15-0ubuntu10.2 is to be installed
libcurl4-gnutls-dev : Depends: libcurl3-gnutls (= 7.22.0-3ubuntu4.1) but 7.22.0-3ubuntu4 is to be installed
                   Depends: libgnutls-dev but it is not going to be installed
                   Depends: libidn11-dev but it is not going to be installed
                   Depends: libkrb5-dev but it is not going to be installed
                   Depends: libldap2-dev but it is not going to be installed
                   Depends: librtmp-dev but it is not going to be installed
                   Depends: zlib1g-dev but it is not going to be installed
share|improve this question

1 Answer 1

Used following command to install all the dependencies

apt-get build-dep <package>
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.