Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I bought a Dell inspiron 17R 5721 it has 2 graphics cards, an Intel(R) HD Graphics 4000 and a AMD Radeon HD 8730M. Intel's card (on board) works just fine after doing what it says in this article.

With AMD's card, no such luck. I've tried to install the catalyst drivers that ubuntu suggests but no luck. I checked on AMD's website for drivers, it's in version 13.04 for about a month and some now, and that version, doesn't list my card as supported.

Does anyone know if I can make my graphics card work with ubuntu 12.04?

share|improve this question
    
Have you tried this? askubuntu.com/questions/124292/… –  Leo Jun 3 '13 at 9:22
    
Thanks for your reply. Nope, I never found that one. I'm gonna give it a try and let you know. –  Deus Deceit Jun 3 '13 at 9:28
    
Please provide info about the application and if you installed the fglrx driver from AMD. –  Manuel Jun 3 '13 at 9:29
1  
I tried all 3 suggestions of additional drivers that ubuntu gave me to choose from, and tried to install the drivers from AMD's web page .run file. But when I tried to install that it said that they won't fit for my graphics card or something like that. I guess fglrx is that .run file right? I did all these stuff the last 2days and I'm sleepless because of this problem. Sorry that my information aren't so clear. –  Deus Deceit Jun 3 '13 at 9:33
    
Have a look here wiki.cchtml.com/index.php/… –  Manuel Jun 3 '13 at 9:53
show 4 more comments

2 Answers 2

up vote 0 down vote accepted

Try with the beta driver of this month following the tutorial of this answer:

What is the correct way to install ATI Catalyst Video Drivers (fglrx)?

Beta Driver: http://www2.ati.com/drivers/beta/amd-driver-installer-catalyst-13-6-beta-x86.x86_64.zip

I suggest to try with the beta driver because the changelog says that adds support your graphic card: http://support.amd.com/us/kbarticles/Pages/AMDCatalyst13-6LINBetaDriver.aspx

share|improve this answer
    
Obviously they are not stable, but is better than one that doesn't support your graphic card. At the end of the month I expect to have the stable driver of 13.6. –  Leo Jun 3 '13 at 19:10
    
Thanks for the answer but changelog doesn't mention my graphics card. Damn it and I was about to become happy. I guess I'll have to wait. Weird thing is that the first time I looked, I could swear it was in it. Then AFTER I re-installed ubuntu and downloaded the drivers, I got the Your card is not supported message. Then I look at the changelog again... and my card wasn't there indeed. :S –  Deus Deceit Jun 4 '13 at 8:07
    
That's true, the 8730M is not supported yet. Well, you can try with the opensource ones that are enabled by default when you install Ubuntu. –  Leo Jun 4 '13 at 9:15
    
No luck with that either, I tried that on my first install, it gave me 3 choices, I tried them all, no luck. Thanks for your effort tho, I really appreciate it. –  Deus Deceit Jun 4 '13 at 11:15
    
I marked this one as an answer because AMD released drivers that support my graphics card. So this answer can be a "hint" for others to look at amd's website. –  Deus Deceit Jan 26 at 21:34
add comment

To have the very latest AMD drivers, you should try the worg-edgers PPA:

https://launchpad.net/~xorg-edgers/+archive/ppa

It solved the same kind of problem on one of my Ubuntu 12.04 workstation.

share|improve this answer
    
I installed the package for ati drivers (not from edgers tho, normal ones) from that site already and what i got was boot failure. The laptop was booting and stayed at black blank screen. Had to re-install to try the rest of choices. Do you have the same graphics card or same series? Cause from what I found out so far, there's no driver for my graphics card. –  Deus Deceit Jun 3 '13 at 18:03
    
did you download the driver from amd website? –  ttoine Jun 4 '13 at 12:25
    
You mean when I tried to install the drivers from the site you posted? If I had ati drivers already installed? If yes, the answer is no, I did that on a fresh install. If that's not what you mean then: I tried the drivers from amd website, beta and released ones, they didn't work, I tried the drivers that ubuntu offer from scratch, no effect either. I just don't think my card will function at the moment. I have to wait for the drivers i guess. –  Deus Deceit Jun 4 '13 at 12:57
    
but did you add the PPA to your list of repositories? –  ttoine Jun 10 '13 at 11:49
    
Yup, added the PPA. For now I'm still using the onboard graphics card of my laptop, thank god it's there. –  Deus Deceit Jun 11 '13 at 15:41
add comment

protected by Community Nov 18 '13 at 19:33

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.