Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a ubuntu 12.04 running and have certain things installed like samba,nagios and likewise-open to have my ubuntu join a windows domain. this all works correctly. I am not an expert in linux although I do know some basics.

What I am trying to do is use deja-dup to backup my ubuntu machine to a windows shared folder with the windows-share method?

at the server line I filled in the ip-address of my windows server.

at the folder I put /smb://"mywindowsserver"/folder

username is the username I created for backing up. (I have read somewhere that it usually works to have the same usernames on a Windows server and Ubuntu machine with backing up)

domain name my domain name.

I am not sure I have the syntax right at the folder it is supposed to back up to

When I click backup now it does connect to the windows server and it asks for a password. After I fill it in and press enter it says that it can't mount the windows share. When I go to that server with Ubuntu file explorer, it just connects and mounts the folder fine.

Has this something to do with permissions? Or am I doing something wrong?

share|improve this question
    
Possible dup of: askubuntu.com/questions/300733/… – Gray Dec 8 '15 at 18:40

I had the same issue. Following rbello1824's link I was able to resolve it. I had to select the custom location option and manually enter the location as:

smb://WORKGROUP\Username@server/Folder

Worked perfect! Thanks rbello!

share|improve this answer
    
That worked. Just as a hint, use %20 for spaces in the share name. – ortang May 5 '14 at 18:38
    
Semicolon instead of the backslash seemed to be helpful for us although using the IP of the server was the real solution. – Gray Dec 8 '15 at 18:49

I'm experiencing the same issue. I found this somewhat old bug https://bugs.launchpad.net/ubuntu/+source/deja-dup/+bug/1018488 that suggest issues with the smb path. I've changed the URI in storage->backup location(custom location) to use the correct format. I'm not sure if this is a fix but will test this evening when I'm able.

share|improve this answer

I am running 14.04 (Trusty Tahr) I am able to connect to my windows share folder by using setting the Storage location as a Custom Location. I set the URI to smb://WindowsServerName/$haredFolderName. Once I set these two fields deja-dup worked correctly. The windows share I used was already set up on my computer. Hope this helps,

Cheers

share|improve this answer

I had a similar problem with entering the correct storage location on my Ubuntu 14.10. I had no success with Backup location set to Windows Share. After changing to Custom I tried using a URI in the form of:

smb://WORKGROUP\Username@server/Folder`

from the answer above, which didn't work either. As I am using nemo as file manager I checked the URI to the shared folder, where I saw an URI in the form of

smb://domain;username@server/sharedfolder/folder

The difference is the semicolon between domain/workrgoup and username. This finally worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.