Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an HP g4-1387 notebook which came with Windows Vista x64 so I removed it and Installed Windows 7 with Ubuntu 12.04 x64 installed. Today I replaced Windows 7 with Windows 8 x64 and obviously grub was removed, so with a LiveUSB I was going to repair grub, but when I try to boot with the LiveUSB I made with Unetbootin as always, but all I get is a black screen with cursor:

enter image description here

I have not any Fast Boot or UEFI option on my BIOS (my laptop is a HP g4-1387). I disabled Fast Startup as described here but nothing happens.

Here I see that I should get an option in the UEFI menu to use a device, but I don't get this option when I enter on UEFI menu (Shift+Restart).

What can I do? Or I am forced to go back to Windows 7 to use Linux?

share|improve this question
    
Press ESC while the computer is restarting, and then press F9 for boot options, do you see an entry for your existing Ubuntu installation there? About your LiveUSB, is it the same that you used to install from it before? I would assume it is something wrong with it. The blank screen issue is a recurring question here. Could you specify whether your setup was UEFI before, with Windows 7, or you migrated from BIOS to UEFI just now? –  Mike C. Jun 3 '13 at 14:15
    
Pressing ESC and then F9 yes, I can see my USB, and when I boot from my USB I get that black screen but I don't get anything else. If I disconnect the USB while in the black screen I get "Error while loading SO". No, is a new image, I will try with another USB today. As far as I know my previous Windows 7 wasn't UEFI, I installed it normally. –  Andres Jun 3 '13 at 14:35
    
Sorry, I tried with another USB and it worked perfectly –  Andres Jun 3 '13 at 16:42
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.