Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

In my college we have only little permission to use files.i need to copy some C programs from other users to my account.

I cannot copy it to /tmp and then copy it back to my account from there, because the cp and mv commands are blocked here.

When I copy something to tmp we cannot even have the read permission on it.

Can you please give a good solution for this?

share|improve this question
    
Well did you try sudo cp FILE –  Luis Alvarado Mar 14 '11 at 16:26
    
I'm pretty certain that since its a college setup, they can't use sudo. A similar setup is at the University I attend, and we definitely can't use sudo. –  Thomas W. Mar 14 '11 at 17:03
    
sudo cannot be used because we dont have the password for that. i tried with nano and after a week nano is also blocked. thanx –  Akhil Pm Mar 16 '11 at 16:34
1  
I'm going to go out on a limb and say that your University does not want you to have access to other users' data and programs. If the users who own the programs want to give you the programs, why can't they just use a flash drive to transfer the programs (i.e. they put it on the disk and you get it off that disk later) –  Thomas W. Mar 19 '11 at 5:19
1  
@EvilPhoenix - because he can't mount drives. I agree with your suposition that the University does not want to allow copies on these machines. –  laurent Mar 20 '11 at 18:44

5 Answers 5

We see that the admin pretty much tied all your hands not to be able to perform tasks like this. I guess the best solution would be to write a message directly to him/her and ask for a solution on your problem.

share|improve this answer
    
best answer in my opinion. –  RolandiXor Mar 20 '11 at 2:37
    
I believe the community is agreed in this regard. –  Thomas W. Mar 20 '11 at 23:18

Do you have access to mounting USB drives? Perhaps you could also create a /home/you/tmp and using that instead of /tmp . Of course, this also assumes that you do not have sudo privileges. If you are able to use sudo, then you could also do as CYREX says.

share|improve this answer
    
mounting,ownership changing and userad etc are not possible. i tried it from the very begining............thanx –  Akhil Pm Mar 16 '11 at 16:42
    
hi friends thanks to all your suggestions and also one glad news. i got the solution for my questions –  Akhil Pm Mar 21 '11 at 11:29

if you can use scp you can do:

scp other_user_login@localhost:/home/other_user_login/file_you_need .

from your account and in the diretory you want to put the file. (you can also change the . to the file location you want on your account)

(other_user_login password will be asked of course)

share|improve this answer
    
i tried scp but it is not possible. is there any method of inserting files into other using emacs and similiar text editors?(we are using emacs in our lab). thanx –  Akhil Pm Mar 16 '11 at 16:36
    
I don't think you will be able to transfer with a text editor but if you have internet available, I guess your friend can always compact the files and send to you by e-mail or to a virtual disk like dropbox. –  laurent Mar 16 '11 at 17:07
    
no we cannot connect to the internet.i think its a homegroup .i'm pretty sure because there is a separate networking lab for us and this lab is only meant for programming. –  Akhil Pm Mar 19 '11 at 4:38

You can try to use python web server in your friend's directory:

python -m SimpleHTTPServer 8000

and connect from your user with firefox using http://localhost:8000. If it works, you'll see the directory where the webserver was started and you will be able to "download" the files to your user.

Maybe you'll have to do this on 2 different machines (and change localhost:8000 to proper ip or name of course) because you can't close the terminal running the web server.

share|improve this answer

As laurent-rpnet mentioned use SCP. If this service is disabled then you can also try ftp.

try : ftp 0 This will connect to the same machine. and provide the username and password of your friend.

share|improve this answer
    
i never tried this...thanx for your suggetion.is dis is the full syntax to connect to a server? –  Akhil Pm Mar 16 '11 at 16:47
    
Yeah to connect to the same server from which you are firing the command. I think 0 works with all the network tools as local host. –  Abhijeet Mar 16 '11 at 19:09
    
sorry, again ftp is also not connecting.I think they banned ftp too. –  Akhil Pm Mar 19 '11 at 4:25

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.