Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've just done a clean install of 13.04 and have been busy trying to get everything configured. I have a working setup at this point, but one item is annoying me.

My wired connection can't be edited via the Gnome settings panel, nor via nm-connection-editor. Here's what's in /etc/network/interfaces

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto p3p1
iface p3p1 inet dhcp

and here is the context of /etc/NetworkManager/NetworkManger.conf

[main]
plugins=ifupdown,keyfile
dns=dnsmasq

[ifupdown]
managed=true

My understanding is that the managed=true should allow me to control it via NetworkManager. Does that not include editing it?

FWIW, the issue for me is that I need to force dnsmasq use, but not resolvconf. The only way I could figure out to do this is to remove resolvconf. When resolvconf is installed, the dhcp nameservers get inserted into resolv.conf with is undesirable since it interferes with correct operation when I bring up my VPN.

What I've got works, it just seemed inelegant to have to do the hand edits and it was surprising that I couldn't edit the configuration from the system settings control panel.

share|improve this question
    
You shouldn't have to remove resolvconf. If the DHCP-obtained nameserver addresses come in via NetworkManager then use the NM connection editor to change the configuration Method from Automatic (DHCP) to Automatic (DHCP) addresses only. If the DHCP-obtained nameserver addresses come in via ifup then either configure dhclient not to send the addresses to resolvconf. –  jdthood Jun 5 '13 at 8:36

2 Answers 2

You cannot edit /etc/network/interfaces via the NetworkManager connection editor.

share|improve this answer

Remove the line

iface p3p1 inet dhcp from /etc/network/interfaces

and restart the network-manager service with

sudo service network-manager restart

The reason is the one stated by @jdthood, network-manager cannot modify connection settings that are from /etc/network/interfaces

share|improve this answer
    
Solution worked perfect! –  Muhnamana Jan 10 at 17:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.