Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I get this message during booting of my laptop:

[14.255596] kvm disabled by bios

Can someone explain this?

share|improve this question

2 Answers 2

Well, is more or less what the error says. KVM is a Kernel-based Virtual Machine and some BIOS block the instructions that KVM uses. You can try some fixes in case that your BIOS is blocking it and the BIOS has KVM enabled:

  • On some hardware (e-g HP nx6320), you need to power-off/power-on the machine after enabling virtualization in the BIOS.
  • Enabling some BIOS features may break VT support on some hardware (e-g Enabling Intel AMT on a Thinkpad T500 will prevent kvm-intel
    from loading with "disabled by bios")
  • On some Dell hardware, you also need to disable "Trusted Execution", otherwise VT will not be enabled.

http://www.linux-kvm.org/page/FAQ#.22KVM:_disabled_by_BIOS.22_error

share|improve this answer

In my case, an IBM T60, it was a bios-setting about the CPU, that had to be enabled. "When enabled, a WMM can utilize the additional hardware capabilities provided by Intel (R) Virtualization Technology."

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.