Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've noticed that running apt-get update recently has resulted in quite a few ppa's returning "403 Forbidden". In and effort to clean them up I had a look:

W: Failed to fetch 403 Forbidden

W: Failed to fetch 403 Forbidden

E: Some index files failed to download. They have been ignored, or old ones used instead.

The strange things is, if I copy these URLs into my browser I can access the files just fine. Why would apt-get report "403 Forbidden" if they're still accessible? I tried re-adding the ppa through add-apt-repository which downloads the signing key again, and it still reported "403 Forbidden".

share|improve this question
i don't have squid or any other proxy, and still get these errors – Berry Tsakala Jun 7 '14 at 12:39
up vote 13 down vote accepted

So it turns out this is an issue with squid-deb-proxy. Unfortunately it doesn't add PPAs and other repositories and just fails with an rather unexpected 403 error.

You can fix this by adding the repositories to the config file:


# launchpad personal package archives (disabled by default)                                                                     

Of course, uninstalling squid-deb-proxy also works around the issue:

apt-get remove squid-deb-proxy
share|improve this answer
For the curious, this means uncommenting the line in /etc/squid-deb-proxy/mirror-dstdomain.acl.d/10-default. – Nathan Osman Dec 21 '14 at 23:38
Don't forget to sudo service squid-deb-proxy restart after doing this. – Power-Inside Feb 28 at 12:15

Are you using proxy?

I have often experience this error, even when using main server.I noticed that this happens when apt-get process breaks for some reason. For instance when running apt-get update downloading of some file coudn't be completed. You will there after get 403 error for that particular file.

I learned that these partially downloaded files (I am not sure if they are exactly the files) during apt-get update are stored in /var/lib/apt/lists/partial/

So I did sudo rm -r /var/lib/apt/lists/partial/*(deleted all files in the directory)

After this I din't get the 403 error.

If you are getting the error when running apt-get install or apt-get upgrade or apt-get dist-upgrade

try sudo rm -r /var/cache/apt/archives/partial/*

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.