Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After some months, my Chrome(now 10.0.648.127 beta; but I tried with the lastest stable too) displayed some popular sites in English, instead of my Chrome & system language, which is Hungarian...

I saw my User-Agent, which shows in Chrome: Mozilla/5.0 (X11; U; Linux i686; en-US) AppleWebKit/534.16 (KHTML, like Gecko) Chrome/10.0.648.127 Safari/534.16

But in Firefox: Mozilla/5.0 (X11; U; Linux i686; hu-HU; rv:1.9.2.15) Gecko/20110303 Ubuntu/10.04 (lucid) Firefox/3.6.15, what is correct...

My question is: How can I change my user-agent(maybe dynamically, by version)? I tried with google-chrome --user-agent "text", but it failed in the newest versions.

share|improve this question
add comment

1 Answer

up vote 1 down vote accepted

In the Google Chrome menu (looks like a wrench), look under Options > Under the Hood > "Web Content" > Languages and spell-checker settings.... There, you should be able to list your preferred languages in priority order.

It seems like this is a bug. It should indeed default to the default locale for your user account.

Edit: I just noticed that this method doesn't actually change the user-agent. (Just the other standard headers that indicate the language -- "Accept-Language" I think?) However, there is a plug-in that should allow you to customize this. (though from the comments, it looks like this, too, might have bugs.)

It's too bad web sites are still looking at User-Agent instead of Accept-Language. (It's... so 1990s.)

share|improve this answer
    
hmmm, I think you are right! - thanks! –  B. Roland Apr 21 '11 at 5:56
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.