Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When executing this list of commands:

xrandr --output DFP3 --mode 1680x1050 --rate 60
xrandr --output CRT1 --mode 1680x1050 --rate 59
xrandr --output DFP3 --left-of CRT1 (error here)
xrandr --output CRT1 --primary

I have this output:

xrandr: screen cannot be larger than 1680x1680 (desired size 3360x1050)

I looked up and they recommended me to add a line in xorg.conf adding Virtual 3360x1050 to the Display subsection. I added it and made a reboot but I have the same error. Here is my xorg.conf:

Section "ServerLayout"
    Identifier     "aticonfig Layout"
    Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
    Identifier   "aticonfig-Monitor[0]-0"
    Option      "VendorName" "ATI Proprietary Driver"
    Option      "ModelName" "Generic Autodetecting Monitor"
    Option      "DPMS" "true"
EndSection

Section "Device"
    Identifier  "aticonfig-Device[0]-0"
    Driver      "fglrx"
    BusID       "PCI:1:0:0"
EndSection

Section "Screen"
    Identifier "aticonfig-Screen[0]-0"
    Device     "aticonfig-Device[0]-0"
    Monitor    "aticonfig-Monitor[0]-0"
    DefaultDepth     24
    SubSection "Display"
        Virtual 3360 1050
        Viewport   0 0
        Depth     24
    EndSubSection
EndSection
share|improve this question
    
This seems to be your monitor sized bigger. Do you have more information about where you installed it? on Windows 7, XP, or Vista using Wubi, CD (burned), Virtual PC/VMware/VM Workstation, or Ubuntu Installer CD (Orignal) Please answer so we can identify your problems. Don't forget the specs of your Computer so we can identify if there's incompatible to install Ubuntu. –  jd434 Jun 2 '13 at 6:05
    
It is a Xubuntu install, using it as my main OS. And the size of the display is OK and has nothing to do with the problem. –  Pacha Jun 2 '13 at 6:07

2 Answers 2

I had the same issue and discovered that I had to extend the height as well as the width to make it work (thanks to ThomasKl's edit to his answer for this question).

Try

Virtual 3360 3360

in the Display subsection.

share|improve this answer

-----------------------SOLUTION FOR xrandr: screen cannot be larger than-------------

Step .1 Check if you have xorg.conf file in /etc/X11 .....yes: goto step 3 else step 2

Step .2 Create xorg.conf file using following step

             Step 2.a    switch to console mode: Alt+Ctrl+F1
             Step 2.b    kill x server: sudo service lightdm stop
             Step 2.c    generate new xorg.conf file: sudo X -configure -- this
                         will create xorg.conf.new file in your current dir
             Step 2.d    rename and move: sudo mv xorg.conf.new /etc/X11/xorg.conf
             Step 2.e    return to GUI: sudo start lightdm

Step .3 Open /etc/X11/xorg.conf and add "Virtual 3200 1080" under subsection "Display"

             Step 3.a    vi /etc/X11/xorg.conf
             Step 3.b    Add "Virtual 3200 1080" to ALL SubSection "Display" 
                         FOR ALL SCREEN if you have more than one "Display"
                         Subsection and more than 1 screen (replace 3200 1080 
                         with your desired screen resolution)
                         FOR EXAMPLE:
                                Section "Screen"
                                Identifier "Screen1"
                                Device     "Card1"
                                Monitor    "Monitor1"
                                     SubSection "Display"
                                           Viewport   0 0
                                           Depth     1
                                           Virtual 3200 1080
                                     EndSubSection
                                 EndSection
                                Section "Screen"
                                Identifier "Screen2"
                                Device     "Card1"
                                Monitor    "Monitor1"
                                     SubSection "Display"
                                           Viewport   0 0
                                           Depth     1
                                           Virtual 3200 1080
                                     EndSubSection
                                 EndSection

Step 4. Restart your computer/laptop

Step 5. Create a script (vi /etc/X11/dual_monitor.sh) and include following

     xrandr --output DVI-0 --mode 1280x1024 
     xrandr --output DVI-1 --mode 1920x1080 
     xrandr --output DVI-0 --auto --right-of DVI-1 --pos 1920x0 

change the file permission chmod 755 /etc/X11/dual_monitor.sh (note: my screen1 is DVI-1 and screen2 is DVI-0, and replace resolution as per need) Step 6. Execute the script and see if it works. (/etc/X11/dual_monirot.sh)

Step 7. If the script works, include the script to Auto Start

    Menu >> Settings >> Session and Startup >> Application Autostart >> Add 
            Name: Dual Monitor Xfce 
            Description: Dual Monitor Xfce 
            Command: /etc/X11/dual_monitor.sh

Step 8. Restart and enjoy

Step 9. Redo step 7 for all users logged in as the user

(Please let me know if it worked shasankh@hotmail.com)

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.