Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed a new motherboard and processor combo tonight and can not fix grub.

I tried auto grub reinstall in the ubuntu installer rescue system. Nothing.

I tried several of the guides around the web all relating to a live CLI and installing GRUB. I have tried several times and no luck. I get a sucesfull install to sda. minus the sector 32 flexnet error.

When I try to boot I get error: no such device: (UUID that dosent match) and then I am at grub rescue. I have 5 drives, all installed in the same order in the BIOS. 4 of them are linux LVM. If i try to boot from one of them I get a nice error message warning me. So I know I am booting to the right device. I just cant get it to let go of the old UUID and find a new one.

I tried: sudo grub-install --recheck /dev/sda
sudo grub-install --root-directory=/ /dev/sda I tried several times, several ways. I have 12.10


this morning I found that even deleting the grub.cfg and running grub-update still pulls the same UUID's. Where are these bring pulled from and how do I update there.


further confused. The UUID's in grub.cfg are all right. The one that is coming up at the boot error does not match any of the drives and does not match the ones in the grub.cfg

share|improve this question
    
I think your not re-installing properly. / can't be your root directory on a rescue CD. It should be something like /media/other_disk/ –  coteyr Jun 2 '13 at 3:36
    
The built in rescue on Ubuntu Server actually mounts your root and runs it as the root. –  JpaytonWPD Jun 2 '13 at 10:42
add comment

1 Answer

The BIOS had a IDE emulator setting for the sata drives. This caused confusion in grub because It was trying to communicate with the sata directly rather than the emulated IDE.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.