Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

for the moment I'm downloading torrents via magnet sing Transmission, when the first time I was asked by chromium to open the magnet URL, I choosed Transmission and I checked the Remember my choice for all links of this type.

Now I want to change the default torrent program for Magnet URL I want to open them using KTorrent.

How can I do that ?

share|improve this question

2 Answers 2

A few things from this thread:

Chromium - or any other browser - doesn't choose which application to use for launching any external application. It relies on the OS for that.

You can use gvfs-mime to reconfigure it again if you need to change your previous setting

gvfs-mime --set x-scheme-handler/magnet KTorrent.desktop

NB: KTorrent must be available. For me I use deluge so my command uses deluge.desktop which was available in /usr/share/applications/

Hope this helps out.

share|improve this answer

You need to change the "Handlers" setting. From this page:

  1. Click the Chrome menu on the browser toolbar.
  2. Select Settings > Show advanced settings.
  3. In the "Privacy" section, click Content settings.
  4. In the dialog that appears, find the “Handlers” section. Click Manage handlers.
  5. Use the drop-down menu next to a listed protocol to select the web service that should be used by default.

If that doesn't work then you can try deleting the correct line from the state file. Instructions here shold help get you started, there for google-chrome, but should be close enough. You basically find the line in your state file, delete it, and that makes the popup show again.

share|improve this answer
This did not work for me. There was no 'magnet' or 'torrent' protocol listed in 'Handlers'. – Gabriel Apr 11 at 18:30

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.