Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
  • Is it not possible at all to install Ubuntu just with a live CD? Do I need to install it with a live USB?

  • At first hand I installed rEFIt which enables to see the ubuntu live CD but when chosen to boot from it, just black screen with blinking cursor. Fn+F6 did nothing for me. Saw on some documentations installing refind and changing screen configurations on macHD.

Well, the screen configs have to be built from start, is that it? None of the documents for screen boot in EFI already exists on mac system, so I need to create it from scratch, is that really it?

  • I’ve downloaded isos - 12.04 amd64, 12.10 amd64 and 13.04 i386. See the point here is, latest macbook pro versions are intel based, so I’m in doubt if amd64 is really the best iso for it. Just to mention, none of the three above downloaded boots to a grub or to a install “Try Ubuntu” screen. All 3 just boots to a black screen with blinking cursor and after a while, just black screen, again, hitting C or Option-Alt or Fn+F6 did nothing.

  • For starters, to see which model i had, none of the documentation where true. the steps that worked out for me were

    sudo su
    admin pass
    sysctl hw.model
    

that gave me the answer: macbookpro9,2

In my “about this mac” the answer is 10.8.3, 13-inch, Mid 2012, Processor 2.5 GHz Intel Core i5, Memory 4 GB 1600 MHz DDR3, Graphics Intel HD Graphics 4000 512 MB, Software OS X 10.8.3 (12D78).

Thanks for the patience. Building a document in portuguese compiling the research, can be seen here https://docs.google.com/document/d/15237Vio3_DRnecg-WuJm-Oz_y5rFMKXGN00G_2uUSUU/edit


PS

Just for stating, partitions are like this right now

* Report for internal hard disk *

Current GPT partition table:
 #      Start LBA      End LBA  Type
 1             40       409639  EFI System (FAT)
 2         409640    787271607  Mac OS X HFS+
 3      787271608    788541143  Mac OS X Boot
 4      856410112    976773119  Basic Data

Current MBR partition table:
 # A    Start LBA      End LBA  Type
 1              1       409639  ee  EFI Protective
 2         409640    787271607  af  Mac OS X HFS+
 3      787271608    788541143  ab  Mac OS X Boot
 4 *    856410112    976773119  0c  FAT32 (LBA)

MBR contents:
 Boot Code: Unknown, but bootable

Partition at LBA 40:
 Boot Code: None (Non-system disk message)
 File System: FAT32
 Listed in GPT as partition 1, type EFI System (FAT)

Partition at LBA 409640:
 Boot Code: None
 File System: HFS Extended (HFS+)
 Listed in GPT as partition 2, type Mac OS X HFS+
 Listed in MBR as partition 2, type af  Mac OS X HFS+

Partition at LBA 787271608:
 Boot Code: None
 File System: HFS Extended (HFS+)
 Listed in GPT as partition 3, type Mac OS X Boot
 Listed in MBR as partition 3, type ab  Mac OS X Boot

Partition at LBA 856410112:
 Boot Code: None (Non-system disk message)
 File System: FAT32
 Listed in GPT as partition 4, type Basic Data
 Listed in MBR as partition 4, type 0c  FAT32 (LBA), active
share|improve this question

4 Answers 4

First, the "AMD64" name refers to the AMD64 architecture, which was invented by AMD and later adopted by Intel. Most current Intel CPUs use the AMD64 architecture -- although of course Intel refuses to use that name. Other names for this architecture include x86-64, x64, and EM64T. In other words, the AMD64 version of Ubuntu is the right one to use for any mainstream 64-bit computer. (It'd be another story if you were using a computer with an ARM, Itanium, SPARC, or other CPU type.)

Second, I'm the maintainer of rEFInd, and I've received several reports from users of recent Macs to the effect that rEFInd doesn't work with them. It appears that Apple has done something strange with the video modes of these models, so rEFInd produces a blank display. Chances are the same is true of rEFIt and of GRUB (which Ubuntu uses by default). Unless/until I can get my hands on such a computer for debugging, or another developer does the same and submits a patch, the rEFInd problem won't go away. The same is probably true of other boot loaders. Given the fact that the problem exists in multiple boot loaders, and even in a very simple test program I created to help a user debug the problem, I'd say this qualifies as a bug in the firmware, although I'm sure Apple would dispute that claim and say they're using some new Apple-specific "standard."

My best suggestion for a workaround is to try using BIOS mode to install Linux. Use Apple's Boot Camp to prepare your disk, then hold down the Option key while starting the computer with the Ubuntu disc inserted to get Apple's own boot manager. You should be able to boot the Ubuntu installer (probably mis-identified as Windows) into BIOS mode and do an install. You'll then need to use gptsync or gdisk to re-create the hybrid MBR. If this is entirely successful, you should be able to use the Option key at boot time to choose between booting OS X and Linux. If/when the firmware/video problem is overcome, you should be able to install a fixed boot manager and begin booting in EFI mode via the updated boot manager.

share|improve this answer
    
thanks for the hint Rod, searching on –  lostcause Jun 3 '13 at 21:39

I was able to use the new AMD64 Mac version of 13.04 and it just worked. I also have a 9,2 mbp. I tried following guides using rEFInd and was struggling to get anywhere. So I just decided to start all over and just try using the installer like I would on a windows PC. I removed rEFInd using the instructions on the site. I deleted all the other partitions that had been created and expanded the Mac OS X partition to full again.

  • I used Disk Utility to create 50GB free space first.
  • Then booted holding ALT and selecting the thumb drive I had Ubuntu on.
  • Just followed the install and selected "Install Ubuntu along side Mac OS X". It chose what to do with the grub/boot install automatically.

After a reboot, and holding ALT again to choose what to boot to, it shows a 50GB "Windows" partition to boot to for Ubuntu. But everything works.

I had to enable wifi drivers after the fact, wifi at work doesn't play nice with Ubuntu for some reason.

share|improve this answer

First, don't use rEFIt or rEFInd. Everybody says you need it for some reason, but I have no idea why. I recommend uninstalling rEFIt.

Secondly, you need the amd64 ISO. Don't get scared off by the word 'amd', they are for Intel processors too.

Thirdly, you should do it with a LiveUSB. I do not recommend installing with a LiveCD because that causes a long startup time and heating issues (Because it then installs in BIOS mode, which is bad, instead of in EFI mode, which is good. LiveUSB's install in EFI mode.). With UNetbootin is easy to create one. Just plug in your USB stick (and unplug all other USB drives if you have them plugged in to.) Start up UNetbootin, select the ISO (I should do that instead of just choosing a distro from the dropdown menu's), and click OK. Wait until it's finished, ignore the message about that it's not bootable on a Mac, reboot your Mac while holding alt, and select the USB drive. The Ubuntu LiveUSB should boot now.

Last but not least, if you have an NVidia graphics card and want to install the "propietary drivers" (Which I HIGHLY recommend if you have an NVidia card, otherwise you'll run into severe graphics performance issues), you will run into issues.

share|improve this answer

Personal experience:

I have downloaded the 64-bit mac Ubuntu Raring Ringtail 13.04. Partitioned my MacHD using Disk Utility. Put it on a USB and used Unetbootin to make it bootable. Shut down my Macbook Pro 9,2 (OS X 10.8.5). Inserted the USB.

Pressed alt (option) key and start button, Macbook sees my EFI (USB live) disk.

Chose 'Try Ubuntu without installing'. Then followed exactly what ChrisDeStefano shows here: http://www.youtube.com/watch?v=PYhdXHO_Hzg to partition on Ubuntu and create a swap area. Installed as shown in video. As the Ubuntu installation concluded I pressed restart.

Because my Macbook didn't see Ubuntu I tried installing rEFInd by downloading it on Mac, placing it on the desktop and using the terminal to install it as shown here:

http://www.thatsthewayyoudoit.me/2013/04/how-to-install-ubuntu-1304-on-macbook.html

Shut down my Macbook and - lo and behold - rEFInd sees both Apple and Ubuntu.

Updated the system in Ubuntu, but I still have heating issue on the mac when using ubuntu and can't install Skype... apart from this Ubuntu works fine.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.