Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to set-up a working environment for application development on my lubuntu 12.04 system using this guide.

But upon entering the command bzr launchpad-login mylaunchpadid, I am given an error message:

WARNING: gnome-keyring:: couldn't connect to: /tmp/keyring-UpnHjy/pkcs11: No such file or directory

How can I fix this?

Thanks In advance.

share|improve this question
add comment

1 Answer

The problem here is that launchpadlib the Python library which bzr uses to talk to launchpad.net, is expecting to use the gnome-keyring API to store the credentials in the keyring, when you log in. It appears you do not have the keyring daemon running on your system, when logged in. You can configure your system so that gnome-keyring-daemon gets run on log-in, and the environment variables it sets are part of your session, or you can follow this handy guide, to configure python-keyring to use a plain file in your home directory, to store the credentials in.

share|improve this answer
    
Thank you, it will try that handy guide in the morning. –  user133987 Jun 1 '13 at 21:13
    
I tried this but still get the error, even after rebooting. Although I saw that there was some network activity while issuing this command so it may have worked. –  user133987 Jun 2 '13 at 13:31
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.