Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm using Kubuntu 13.04 x64. I found out about this problem after installing Nvidia drivers from jockey and seeing that nouveau was still loading instead.

I tried to manually reinstall nvidia-current but initramfs-update fails:

$ update-initramfs: Generating /boot/initrd.img-3.8.0-23-generic
E: /usr/share/initramfs-tools/hooks/fixrtc failed with return 1.
update-initramfs: failed for /boot/initrd.img-3.8.0-23-generic with 1.

This errors started after trying to install Nvidia drivers, but it most probably is unrelated. As I understand from fixrtc, it's just trying to set the correct time using time, dumpe2fs and hwclock.

Can you tell me what's happening? I can't build initrd images with initramfs-tools failing on the fixrtc hook.

share|improve this question
Worked around it by removing the executable flag from fixrtc with sudo chmod -x /usr/share/initramfs-tools/hooks/fixrtc. Now update-initramfs completes building an initrd image. Is there anything bad that could happen by removing fixrtc as I did? I'm still curious about what happened! – Montblanc Jun 2 '13 at 0:10

Seems to be magically resolved in 3.8.0-24

share|improve this answer
Stumbled back upon it while upgrading to 13.10. Had to toggle again the executive flag. – Montblanc Oct 18 '13 at 23:55

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.