Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I upgraded from 11.10 to 12.04, now when I try to run Firefox from the icon it pops up this: "Missing Profile. Your Firefox profile cannot be loaded. It may be missed or inaccessible." I already tried to remove Firefox and re-installing it. And the command

sudo chown -R $USER:$USER ~/.mozilla

I've also tried to delete the profile file, or renaming it. I've found some solved problems but they didn't work for me. Maybe I should mention that if I run Firefox from terminal using sudo it starts fine.

Any idea about how could I solve this?

share|improve this question
Well, I've solved it by the moment. I realize that before I upgraded, Firefox was in the version 20.0.1; after upgrading, Firefox is v21.0.0. I've read that Firefox v21 wasn't stable in Linux yet. And maybe that was the trouble, so I downloaded the version 20.0.1 and (I don't know exactly how to install it) ran the file 'firefox-bin' after uninstall the other version and delete de .mozilla folder. It worked! But now Firefox doesn't have is characteristic icon! Can someone tell me to wich folder should I move the Firefox folder (I mean the one that comes in the .tar file)? – Luis J. Romero Jun 1 '13 at 19:23
I had the same issue and I did: sudo chown -R $USER ~/ – Lilian A. Moraru Apr 19 at 7:36

I got the same case, and I tried to change permission of mozilla cache and it worked:

root mode

sudo -s
chown -hR $USER:$USER ~/.cache/mozilla

but after I changed, there's pop-up suggested me when I opened firefox to create a new profile. I just want to use an older profile. So I changed the permission of old profile too into my user!

chown $USER:$USER ~/.mozilla/firefox/profiles.ini

dont forget to make a sure the file permission is changed :)

share|improve this answer
Thanks, I will try it, thought, I solved it with the first answer of this question:… I realize that the problem is with Firefox 21. I installed an old version (20.0.1) and it worked. Maybe now I can update to FF 21 and try what you say. – Luis J. Romero Jun 5 '13 at 2:45
@LuisJ.Romero: If this answer did help, just click the little grey under the "0" now turning it into beautiful green. If you do not like the answer, click on the little grey down-arrow below the 0, and if you really like the answer, click on the little grey ☑ and the little up-arrow... – Fabby Oct 27 '15 at 20:31

Try deleting the current profile. That will force Firefox to create a new profile. Profile folders are located here:

~/.mozilla/firefox/<profile folder> 

The .mozilla folder is a hidden folder. Make sure that you check show hidden files in your file manager (Browser).

share|improve this answer

I just encountered this in 14.04 after an attempt to move files from my previous install failed. I am no expert, but this worked: Edited profiles.ini file in ~/.mozilla/firefox/ commented out (using ; below)


Created a new path line so that the hash matched the [].default folder name in ~/.mozilla/firefox/

Maybe I could have renamed the folder to match the name in profiles.ini, but easier to trace back the problem knowing I could delete the new and uncomment the old Path= from within profiles.ini.

Fortunately for me, I installed 14.04 on a new SSD and kept the old 12.x release. Now I'll try what I should have done in the first place - a proper Firefox profile backup/move from the old installation.

share|improve this answer

After all other solution this little line saved my day:

sudo chmod -R 777 .mozilla/
share|improve this answer

I had the same problem after upgrading to Firefox 23.0. Deleting the profile folder didn't work and i tryed a lot of other tipps found in various forums.

But changing the owner of the cachfolder finaly did the trick. Thanks

share|improve this answer
Thank you for your answer, but can you explain how to change the owner of the folder? – mrcktz Sep 10 '13 at 10:05

Had a similar issue. Had to delete the profiles.ini file in ~/.mozilla/firefox/. Tried all kinds of permissions solutions to no avail. Once profiles.ini was deleted, firefox created a new profile.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.