Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Something went wrong with the kernels of my current installed Ubuntu, and because of this i can't access my Ubuntu installation, so I'm trying to make a back-up using a LiveCD and copying everything to my hard drive.

The issue is that I can't get access to the file system. I can view the files but I can't copy anything. I tried a few commands to fix this but so far all failed.

I tried the chown command, but this always returns the error permission denied

I also tried gksudo nautilus to open a full permission folder but I didn't get any access here too...

Anyone any suggestions??
Thanks in advance.

share|improve this question
    
Did you encrypt your file system perchance? –  RPi_Awesomeness Jun 1 '13 at 13:51
    
no i didn't, never encrypted anything –  Raymond Jun 1 '13 at 23:04

1 Answer 1

-I don't have the rep to comment-

In order to help, I'd need to ask a few questions: -I assume you mean to be copying between two HDDs installed in the same machine, or accessible from the same machine, correct? -When you mention that you can't get access to the file system, how exactly do you mean that? As in you don't know how, or you've mounted it and due to logical errors you can't access it? -You spoke of commands you issued to fix the problem. What commands? What was the output and result of each?

share|improve this answer
    
I meant copying from the built in hard drive of my laptop to an external hard drive, but i don't have the permissions to copy the files from my internal hard drive. I can still see files and view them, i just can't copy them. –  Raymond Jun 1 '13 at 14:16
    
The commands that were used are chown, applied to the internal hard drive, but it gives me the error that i don't have permission to do that, i also tried gksudo nautilus to open an all access folder but this didn't work either –  Raymond Jun 1 '13 at 14:18
    
OK, try to copy them and then post the output showing the error please. –  RGS Jun 1 '13 at 14:32
    
When copying files the following error message occurs: Error while copying. The folder "filefolder" cannot be handled because you do not have permissions to read it. –  Raymond Jun 1 '13 at 23:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.