Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I recently installed ubuntu 12.04 LTS, and have tried every method out there to get my Ethernet cable to work...unfortunately not one of the methods out there worked for me. here are some of the tests i ran:

lspci -nnk | grep -i ethernet gives 05:00.0 Ethernet controller [0200]: Atheros Communications Inc. AR8161 Gigabit Ethernet [1969:1091] (rev 10).

ifconfig gives:

lo Link encap:Local Loopback 
inet addr: Mask: inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:16436 Metric:1 RX packets:803 errors:0 dropped:0 overruns:0 frame:0 TX packets:803 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:0 RX bytes:103034 (103.0 KB) TX bytes:103034 (103.0 KB)
wlan0 Link encap:Ethernet HWaddr 08:60:6e:cd:f6:f3 
inet addr: Bcast: Mask: inet6 addr: fe80::a60:6eff:fecd:f6f3/64 Scope:Link UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:3130 errors:0 dropped:0 overruns:0 frame:0 TX packets:3156 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:`1000 RX bytes:3869261 (3.8 MB) TX bytes:381110 (381.1 KB)

lshw -c network:

*-network UNCLAIMED 
description: Ethernet controller product: AR8161 Gigabit Ethernet vendor: Atheros Communications Inc. physical id: 0 bus info: pci@0000:05:00.0 version: 10 width: 64 bits clock: 33MHz capabilities: pm pciexpress msi msix bus_master cap_list configuration: latency=0 resources: memory:f7200000-f723ffff ioport:d000(size=128) *-network description: Wireless interface physical id: 2 bus info: usb@5:2 logical name: wlan0 serial: 08:60:6e:cd:f6:f3 capabilities: ethernet physical wireless configuration: broadcast=yes driver=rtl8192cu driverversion=3.5.0-23-generic firmware=N/A ip= link=yes multicast=yes wireless=IEEE 802.11bgn

What can I do?

share|improve this question

The 8161 cards have been a source of many problems exactly like yours. You can find a list of posts related to the 8161 cards here. The problem seems to be related to the driver supplied in the current kernel versions; rolling back the driver seems to work for most cases. One suggested fix that apparently worked was to issue the following Terminal commands:

apt-cache search linux-backports-modules
sudo apt-get install linux-backports-modules-cw-3.6-quantal-generic
sudo modprobe alx
share|improve this answer
unfortunately that didn't work either... any other suggestions – user163507 Jun 1 '13 at 17:51
Run through the list of posts that I linked and try the vaariations of fixes. – douggro Jun 2 '13 at 3:02
thanks for your help, but as i have mentioned before i have tried each one of them... and nothing is working... – user163507 Jun 2 '13 at 17:48
Sorry, I don't have anything further to offer other than to continue searching the Interwebs for possible solutions. – douggro Jun 2 '13 at 20:04

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.