Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu 12.04LTS. I am trying to upload to github via SSH. I generated my key using keygen, and made sure that github has the key as specified. However, when I try to ssh in I keep getting a Ubuntu window opening asking for a password. This is not coming from github, but from the Ubuntu system itself. The keys are somehow password protected, which is fine, but I have absolutely no idea what that password might be. It is not my root password. It is not my user password. I never actually set a password for those keys, so I am completely at a loss. I've tried leaving it blank or just a space, but that doesn't work either. I need to either find out what password this is, find a way to reset it to a password that I actually know, or somehow disable it. The only posts I can find on this problem are much older ( 2008 ), and none of the files they talk about editing exist in 12.04.

Editing to clarify one more time. This is a Ubuntu issue, not an SSH issue. There is no issue with the key or the remote host. The problem is with Ubuntu slapping a password on the use of this key without my knowledge and me having no idea what that password might be or how to reset / disable it.

share|improve this question
add comment

1 Answer

Normally if this ssh-copy-id -i ~/.ssh/id_dsa/rsa.pub remote-host works properly it will

append the keys to the remote-host’s .ssh/authorized_key

After that you should be able to login to that particular remote-host without password.

NB: Can you provide some more detail like how you added the key? Also yo can verify that from the user you've generated the key also trying to ssh from the same user.

When no value is passed for the option -i and If ~/.ssh/identity.pub is not available, ssh-copy-id will display the following error message.

jsmith@local-host$ ssh-copy-id -i remote-host
/usr/bin/ssh-copy-id: ERROR: No identities found

You may have a look into the Using ssh-copy-id along with the ssh-add/ssh-agent section of This Link

share|improve this answer
    
ssh-copy-id -i ~/.ssh/id_dsa/rsa.pub remote-host returns the error NO IDENTITIES FOUND. –  Blind Fish Jun 1 '13 at 0:57
    
As for more detail, I generated the keys using keygen. What I am really looking for is exactly what password Ubuntu is looking for from me here. I never set a password for my ssh keys. It's not my root password. It's not my login password. I wouldn't mind entering the password if I had any way of knowing what password it wants me to enter. –  Blind Fish Jun 1 '13 at 0:59
    
And yes, I am trying to use ssh from the same user that generated the key. –  Blind Fish Jun 1 '13 at 1:00
    
@BlindFish Are you sure you didn't enter a passphrase when making the key? How about starting over, and making a new key? –  demure Jun 1 '13 at 1:06
    
Of course I entered a passphrase. That is not what it's looking for. I tried that several times. It's as if the system is set to password protect the keys as a default, which is fine. I totally get that. I'm just blown away that it's not my root password. I have no idea what the password could be or how to go about finding it. –  Blind Fish Jun 1 '13 at 1:10
show 1 more comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.