Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried installing the ATI Catalyst drivers on Ubuntu 12.04, 64 bit version (dual boot with Windows 7 x64 and wubi).

I have tried both the versions of the Catalyst Drivers, 12.8 and 13.1

In both the cases, I have faced an issue of a blank screen after reboot post installation of the Catalyst Drivers.

It loads up the Ubuntu logo and after 5 seconds, the screen goes blank. I have even tried setting the nomodeset option for the kernel at boot up (as suggested in other threads), however the problem persists.

I have followed all the instructions the way they are supposed to. I cannot seem to figure out why do I face this issue of a blank screen everytime.

also, while installing the fglrx *.deb files on the machine, I received an error regarding a bad return status for the kernel. Here is the complete log for the command.

sudo dpkg -i *.deb
[sudo] password for user:
Selecting previously unselected package fglrx.
(Reading database ... 169985 files and directories currently installed.)
Unpacking fglrx (from fglrx_8.982-0ubuntu1_amd64.deb) ...
Selecting previously unselected package fglrx-amdcccle.
Unpacking fglrx-amdcccle (from fglrx-amdcccle_8.982-0ubuntu1_amd64.deb) ...
Selecting previously unselected package fglrx-dev.
Unpacking fglrx-dev (from fglrx-dev_8.982-0ubuntu1_amd64.deb) ...
Setting up fglrx (2:8.982-0ubuntu1) ...
update-alternatives: using /usr/lib/fglrx/ld.so.conf to provide /etc/ld.so.conf.d/x86_64-linux-gnu_GL.conf (x86_64-linux-gnu_gl_conf) in auto mode.
update-alternatives: warning: skip creation of /etc/OpenCL/vendors/amdocl32.icd because associated file /usr/lib/fglrx/etc/OpenCL/vendors/amdocl32.icd (of link group x86_64-linux-gnu_gl_conf) doesn't exist.
update-alternatives: using /usr/lib/fglrx/alt_ld.so.conf to provide /etc/ld.so.conf.d/i386-linux-gnu_GL.conf (i386-linux-gnu_gl_conf) in auto mode.
update-initramfs: deferring update (trigger activated)
Loading new fglrx-8.982 DKMS files...
First Installation: checking all kernels...
Building only for 3.5.0-23-generic
Building for architecture x86_64
Building initial module for 3.5.0-23-generic
Error! Bad return status for module build on kernel: 3.5.0-23-generic (x86_64)
Consult /var/lib/dkms/fglrx/8.982/build/make.log for more information.
update-initramfs: deferring update (trigger activated)
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Setting up fglrx-amdcccle (2:8.982-0ubuntu1) ...
Setting up fglrx-dev (2:8.982-0ubuntu1) ...
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.5.0-23-generic
Warning: No support for locale: en_US.utf8
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place

Please help in resolving this issue.

My Graphics Card is ATI HD 5870.

I have tried both the versions of Catalyst Drivers (12.8 and 13.1). However, the error specific to the kernel appears in the 12.8 version.

I already have the latest update for my kernel as per the command:

sudo apt-get install linux-headers-$(uname -r)
share|improve this question
    
Did you check the log - "Consult /var/lib/dkms/fglrx/8.982/build/make.log for more information." –  bodhi.zazen May 31 '13 at 20:20
    
Ok, I will check that and provide more details. I am trying to install once again. However, do you know why do I get a blank screen everytime I reboot after the installation of catalyst driver (both 12.8 and 13.1)? –  Neon Flash May 31 '13 at 20:35
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.