Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

We run a server with a few dozen vhosted sites, under Apache 2.2.22 on Ubuntu 12.0.4. None of them had a SSL before. We had a client request one the other day, and my issue began shortly after.

I thought I was doing well setting up that client's vhost with SSL. It is rewriting any HTTP request on that domain to port 443 and serving the page on a secure layer. But I realized that any vhost request made with https://, is forwarding to the domain that SSL was set up on. All normal HTTP requests are sent properly.

To sum it up...
We have -

  1. www.example1.com
  2. www.example2.com
  3. www.example3.com

I just set up SSL for www.example3.com, but any https:// request made to example1.com or example2.com, forward to https://www.example3.com.

Is there something I need to add to my httpd.conf file to turn off SSL globally, and within the vhost turn it on for the specific domain?

How may I solve this problem?

share|improve this question
    
I don't know much about Apache, but I think the answer in the following link will solve your problem (Adding Aliases). link : <webmasters.stackexchange.com/questions/17605/…; –  Ahmadgeo May 31 '13 at 18:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.