Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have tried several solutions but nothing works. First of all, I'm using ATI Radeon HD 5400. The first monitor (which works) is connected to the graphic card by DVI, the second monitor (which isn't detected) is connected to the motherboard by VGA. One important point - when I used Windows (yesterday?) the two monitor worked together fine.

What I've done until that moment:

  1. Followed by the instructions here: https://help.ubuntu.com/community/BinaryDriverHowto/ATI#Installation_via_the_Ubuntu_repositories. Installed fglrx by writing sudo apt-get install fglrx. Then typed fglrxinfo in the Terminal and got:

    display: :0  screen: 0
    OpenGL vendor string: Advanced Micro Devices, Inc.
    OpenGL renderer string: ATI Radeon HD 5700 Series
    OpenGL version string: 4.2.11903 Compatibility Profile Context
    
  2. Tried that solution: http://askubuntu.com/a/281117. I installed: http://i.stack.imgur.com/JD9li.png and added in Xorg.conf the following line: Virtual 3600 3600.

  3. System Settings > Details > Graphics displays Driver: VESA:JUNIPER

  4. The second monitor isn't detected either by the Catalysit Control Center nor by System Setting > Display.

  5. $ lspci | grep VGA displays >> 01:05.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RS880 [Radeon HD 4200] 02:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Juniper [Radeon HD 5700 Series] The meaning is that it knows about the existence of the on-board graphic - Radeon HD 4200 (?).

share|improve this question
    
what is the graphic card on your motherboard ? –  ttoine Jun 3 '13 at 12:32
    
Motherboard model is Gigabyte MA785GMT-UD2H, integrated ATI Radeon HD 4200 graphics. –  Luis Jun 3 '13 at 14:31
    
did you changed something in the bios setup between Windows and Ubuntu startups? –  ttoine Jun 4 '13 at 12:27
    
No, I didn't change. –  Luis Jun 4 '13 at 14:02
    
Did you try to install the driver by this way? askubuntu.com/questions/124292/… Maybe is a bug of the version of the repository driver and you need to install the latest: www2.ati.com/drivers/linux/… –  Leo Jun 6 '13 at 21:18
add comment

1 Answer

I am afraid that it is not possible to use both onboard graphics and GPU at the same time. It is either onboard or GPU but not both and probably has nothing to do with your GPU being ATI.

I faced the same problem while it could work on Windows 7 (Nvidia + onboard + two monitors), on Kubuntu 13.03 the second monitor just turned on from sleep but it didn't show anything (black screen).

Linux and the current graphic server, in most cases cannot handle such setup.

Fortunately my GPU had an extra output and my problem solved by using only the GPU.

You can read more about this at http://superuser.com/a/404700/71345

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.