Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a MacBook Pro running VMWare 3.1, inside which I have two VMs - XP and Ubuntu 12.04. The Ubuntu VM was recently upgraded from 10.04 - it is not a clean install.

Until I upgraded, I was able to bridge or use NAT to access the Internet. Now I can't.

I ran ifconfig -a which shows that the loopback is fine, but the eth0 is not:

eth0      Link encap:Ethernet  HWaddr 00:0c:29:d0:69:c5  
          BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:446 errors:441 dropped:0 overruns:0 frame:0
          TX packets:304 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:68933 (68.9 KB)  TX bytes:30736 (30.7 KB)
          Interrupt:19 Base address:0x2024

Using the network tools GUI I can see no IP address or netmask have been set, but it does not permit me to configure them - the button clicks, but does nothing.

There is nothing in the IP routing table when I run route -n. How do I go about fixing this?

share|improve this question
    
This sounds more like a problem with the VM configuration in VMWare than a problem with Ubuntu. Shut down the Ubuntu VM instance and check the networking settings for the VM in VMWare. –  douggro May 31 '13 at 16:36
    
It wasn't. I ran resolvconf and rebooted, and I now have the connectivity I wanted. Mind you, Software Centre threw a number of errors and it took three goes before it ran properly. –  James Mac Jun 1 '13 at 18:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.