Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I can't enter character |, but I have this character on keyboard. I need this for Java (if x == 2 || x == 3)

And second, not important question, but also - Shift + 2 give me ", not @. This keys swiped.

I am on Lubuntu.

Please, give simple solution.

share|improve this question
1  
It sounds to me that you need to go to your System Settings and check that the keyboard is set to the correct country. –  SimplySimon May 31 '13 at 15:00
    
This is on US or GB or RU keyboard layout. Default keyboard model set to pc105 - and from this long list I don't know my keyboard - I have laptop Sony Vaio VGN-C140G. –  Vitaly Zdanevich May 31 '13 at 15:05
1  
Use the key in the left side of the number one to get |, you will get @ by hitting AltGr+2 or AltGr+Q in certain cases. Please confirm if this helps in order to add it as an answer. BTW: AltGr = Right Alt. Thank you. –  Geppettvs D'Constanzo May 31 '13 at 15:10
    
Thanks! I can get | by pushing AltGr + "key-left-before-1", but is it possible to sync physical labels on keyboard with keyboard layout in Lubuntu? –  Vitaly Zdanevich May 31 '13 at 15:20
add comment

3 Answers 3

up vote 1 down vote accepted

Check your Layout Chart by following below images. For english it should be like this:

Layout Chart

So, to use | character, press Shift+\.

If you use another input language, this Layout Chart it will look different. So you need to check how.

share|improve this answer
    
My Dear, I am on Lubuntu. –  Vitaly Zdanevich May 31 '13 at 16:18
    
And what is the problem? You can't find Layout Chart? –  Radu Rădeanu May 31 '13 at 17:06
    
Yes, Lubuntu not have Layout Chart. –  Vitaly Zdanevich May 31 '13 at 17:36
    
@VitalyZdanevich Sure... What you say about this: To add a layout indicator to the panel - right click on the panel - Add / remove panel items - Panel Applets - Add - Keyboard Layout Switcher. –  Radu Rădeanu May 31 '13 at 18:25
1  
Lubuntu does have a layout chart: open Universal Access->On Board –  douggro May 31 '13 at 20:32
show 2 more comments

It looks like you have the wrong keyboard set. The keyboard layout varies in different countries and I have the " on Shift+2; this is the default in the UK.

You were asked what keyboard layout you wanted when you installed but I think it defaults to a UK keyboard. Luckily you don't need to reinstall to change it.

From the Menu select "Preferences" > "Keyboard and mouse"

In the application that opens select the "Keyboard" tab and click lxkeymap as shown

img

This opens a new window

img2

From here you can select the keyboard layout that matches your computer and select Apply.

Job done, the new setting will be remembered.

share|improve this answer
add comment

You can assign the keycode for the | key to another one. (7c is | according to xev)... Hope that helps you out.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.