Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I mount an NTFS partition (where I've got some Linux binaries and scripts alongside with Win32 and data files) with the following fstab line:

/dev/sda5 /mnt/dat ntfs-3g rw,dev,exec,auto,async,users,umask=000,uid=1000,gid=1000,locale=en_US.utf8,  errors=remount-ro 0 0

All files seem to have executable attribute set then, but if I try to actually execute them, I get "Permission denied" error. Even with sudo. Even while execute (as well as read and write) permissions are granted to everyone and all the files owner is set to the user.

So how do I set the system up to be able to run Linux binaries from NTFS?

share|improve this question
2  
possible duplicate of .exe file permission fail –  RolandiXor Mar 14 '11 at 2:01
4  
Hardly even related to ".exe file permission fail" question. I have no problems with .exe files. The question is NOT about running Windows executables on Linux, it is about running Linux executables located on a Windows partition. –  Ivan Mar 14 '11 at 5:33
2  
if you read this carefully - you will see that it is related. Or maybe you don't understand how linux sees executables. The extension doesn't make the difference. –  RolandiXor Mar 14 '11 at 5:39
    
possible duplicate of How to 'chmod' on an NTFS ( or FAT32 ) partition? –  psusi Nov 2 '11 at 15:15
add comment

2 Answers

There were a few people mulling this one over in the chat channels. One of the people suggested that you take a look at George Edison's response to this question, and see if it helps you:
.exe file permission fail

share|improve this answer
2  
I have no problems with .exe files. The question is NOT about running Windows executables on Linux, it is about running Linux executables located on a Windows partition. –  Ivan Mar 14 '11 at 5:31
2  
sigh... please read it carefully. –  RolandiXor Mar 14 '11 at 5:39
add comment

That is the "feature" of udisks package to, by default, restricts permission modification on ntfs partition (or other non-Linux partitions).

To enable this feature, you may want to read,

Enable Setting Executable Permission of Files at NTFS Partition

share|improve this answer
1  
Also related: NTFS-3G: File Ownership and Permissions –  Eliah Kagan Aug 10 '12 at 9:30
4  
The link in this answer is dead :( –  Abby May 3 '13 at 8:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.