I have problems with my PHP installation on my Ubuntu 12.10. I need to install Drush and Memcache for a Drupal project, but they require php5-dev and php-pear.
However when I try to install these packages I get the following error message:
sudo apt-get install php5-dev The following packages have unmet dependencies: php5-dev : Depends: php5-common (>= 5.4.6-1ubuntu1.2) but 5.3.10-1ubuntu3 is to be installed E: Unable to correct problems, you have held broken packages.
So there is a problem with php5-common, but I don't know how to solve it. When I do:
sudo apt-get install php5-common
I get the following result:
php5-common is already the newest version. 0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
I also tried:
sudo apt-get install -f php5-common
But it didn't help. It returned:
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.
Then I tried following this answer.
sudo add-apt-repository ppa:ondrej/php5 sudo apt-get update sudo apt-get upgrade
But I got the same results.