Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I got HP Pavilion dv6 7010ej, using beats audio, how can i enable full audio model support on it (including subwoofer etc.)?

Sound Card:
lspci says:
Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04).
Windows says: "IDT HD Audio".

share|improve this question
    
What is your audio card? If you don't know, type into the terminal: 'lspci' and look for audio. –  nerof61 May 31 '13 at 9:02

3 Answers 3

See my post on Reddit here:

http://www.reddit.com/r/linux/comments/17sov5/howto_beats_audio_hp_laptop_speakers_on/

The model=ref method doesn't work quite right, at least not on my laptop. You have to remap some HD audio ports that appear disconnected and then all the speakers work. There's a convenient little tool out there that does just that. I also got it working under Debian and it works without breaking headphones too.

Step 1: Install hda-jack-retask from here: https://launchpad.net/~diwic/+archive/hda (ppa:diwic/hda)

Step 2: Open hda-jack-retask

Step 3: Select the IDT 92HD91BXX codec (may be different on other models)

Step 4: Check the "Show unconnected pins" box (the internal speakers do not show as connected)

Step 5: Remap 0x0d (Internal Speaker, Front side) to "Internal speaker"

Step 6: Remap 0x0f ("Not connected" but is the under-display speakers) to "Internal speaker"

Step 7: Remap 0x10 ("Not connected" but is the subwoofer) to "Internal speaker (LFE)"

Step 8: Apply now, then test with your favorite audio program (some may not work due to Pulse reset, so find one that does, verify sound is coming from all speakers).

Step 9: If it works, select "Install boot override" to save the settings to apply at boot time.

Step 10: Reboot. When it comes back, you should have full sound from all speakers. Also test headphones. Plugging in headphones should disable sound from all internal speakers.

share|improve this answer
    
This should be accepted as the correct answer IMO. I'd used the model=ref method too and had the same headphone problems. This cleared it up perfectly. Thank you! –  Jeremy Oct 12 '13 at 18:00
1  
However, please put at least the actionable summary text of your entry here - linking to external sites for answers is a great way to make this place into a ghost town when those external sites disappear. –  fluffy Jun 7 at 1:43

This worked for me on Linux Mint, I found it on an HP forum.

Run this command to edit the alsa-base.conf file:

sudo gedit /etc/modprobe.d/alsa-base.conf

Now you need to add this line to the file (as shown in the picture):

options snd-hda-intel model=ref

Now restart your computer for the changes to take effect. This worked for me on 11.04 (Natty Narwhal).

share|improve this answer

This was done in my own HP envy and this process works on all HP laptops containing beats audio.

STEP 1

Install hda-jack-retask from https://launchpad.net/~diwic/+archive/hda . Download this small application according to your version of Ubuntu. After the completion of download, install the app.

STEP 2

After the app is installed, go to the terminal and type hda-jack-retask which opens the file. Open app using terminal

STEP 3

At the top, in codec section, select IDT 92HD91BXX codec.

This code varies with various models. Check it

STEP 4

Check the “ Show unconnected pins” at the right side.

STEP 5

After this, you will see different types of unconnected pins of your sound driver. You have to map these pins to the right part of the beats audio drive. Care must be taken at this point.

You can see there are various types of pins. We are not aware about these things. Even I don’t know

what I am doing and is confusing. BUT do not worry at all.

You just have to play on three pins. They are 0x0d , 0x0f and 0×10.

STEP 6

Go to the section having pin id : 0x0d .

Change (Internal Speaker, Front side) to “Internal speaker”.

STEP 7

Go to the section having pin id: 0x0f.

Change (Not connected) to “Internal speaker”. This part is about the under-display speakers.

STEP 8

Go to the section having pin id: 0×10.

Change (Not connected) to “Internal speaker (LFE)”. This part is about the sub-woofer.

STEP 9

You are finally done with those pin settings. Apply it now. You can test with some sound. Check whether all the speakers are producing desired sound. The settings must be done as in following picture.

Do as it is

STEP 10

If everything is all right, install boot override from the bottom right side and restart your device.

Finally you must have sound with beats audio. Enjoy the sound and music. Also plug in the headphones, it must disable the external sound when the headphone is plugged in.

you can visit here for more information. http://www.chromeearth.com/enable-beats-audio-in-ubuntu/

share|improve this answer

protected by Community Aug 3 at 8:53

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.