Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed the laptop-mode-tools package. When the service starts (term reads "Enabling laptop mode"), a segmentation fault occurs.

I can't boot the system now. I tried to remove the package from recovery mode, but the filesystem is mounted read-only, and selecting an option that would mount it for writing inits laptop-mode-tools and segfaults again.

EDIT: I remounted / with rw, but running dpkg to remove the package also causes a segfault.

Nevermind getting the package to work, how can I recover the system?

share|improve this question
    
askubuntu.com/questions/285434/… –  Qasim May 31 '13 at 9:53

3 Answers 3

When you are in recovery mode, remove the package with:

sudo apt-get remove --purge laptop-mode-tools
share|improve this answer
    
As I said, that also causes a segfault. I used a chroot and solved the problem –  uʍop ǝpısdn May 31 '13 at 7:43
    
@uʍopǝpısdn You said that you runned "dpkg to remove the package". And it was normal to use root privileges. For this I used sudo in my answer. –  Radu Rădeanu May 31 '13 at 8:07

I used the Ubuntu live installation drive to chroot into the local system:

# mkdir mnt
# mount -t proc proc mnt/proc
# mount -t sysfs sys mnt/sys
# mount -o bind /dev mnt/dev
# chroot mnt /bin/bash

Inside the chroot, I could apt-get remove --purge the package with no issues.

Unfortunately for me, the system never booted again. The kernel panics during startup.

share|improve this answer

I entered in recovery mode and delete with rm the /etc/laptop-mode-tools folder with its sub-folders. Then I re-give the command apt-get purge laptop-mode-tools and all works!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.