Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.
$ cat /etc/default/locale
LANG="ru_UA.UTF-8"
LANGUAGE="ru_UA:ru"
$ locale -a | grep ru_UA
ru_UA.iso885915
ru_UA.utf8



~ $

I want to have: $ cat /etc/default/locale LANG="ru_UA.UTF-8" LANGUAGE="ru_UA:ru"

$ locale -a | grep ru_UA
ru_UA.iso885915
ru_UA.koi8r
ru_UA.utf8

That is, I want to add one more encoding ru_UA.koi8r for the locale ru_UA. How do I bring the system to the form ? Advice please!

share|improve this question

2 Answers 2

First, locale -a | grep ru_RU will never return what you write. Maybe locale -a | grep ru_UA.

Second, you can generate new locales by issuing:

sudo locale-gen ru_UA.KOI8-R

I didn't check if ru_UA.KOI8-R is the exact form for what you wish.

More about: (Re-)Generating locales.

share|improve this answer
    
ppm@ppm-VirtualBox ~ $ sudo locale-gen ru_UA.koi8r [sudo] password for ppm: ppm@ppm-VirtualBox ~ $ locale -a | grep ru_UA ru_UA.iso885915 ru_UA.utf8 ppm@ppm-VirtualBox ~ $ sudo locale-gen ru_UA.KOI8-R ppm@ppm-VirtualBox ~ $ locale -a | grep ru_UA ru_UA.iso885915 ru_UA.utf8 ppm@ppm-VirtualBox ~ $ –  Igor May 31 '13 at 8:27
    
@Igor I told you, check for exact form of encoding for ru_UA.KOI8-R –  Radu Rădeanu May 31 '13 at 8:52
    
@Igor I think is ru_RU.KOI8-R or something like this... Try yourself with many variants until you get it. –  Radu Rădeanu May 31 '13 at 8:56
    
But look more closely output of the command I tried koi8r and KOI8-R –  Igor May 31 '13 at 9:03
    
@Igor I don't understand what you mean. I sow that didn't give any result and I told you what you can do. –  Radu Rădeanu May 31 '13 at 9:08

You need to decide which encoding to use; you cannot enable both concurrently.

That said, and since you ask for advice, I would advise you to not use any other locale but UTF-8 locales in Ubuntu. If you do, you may encounter unexpected behaviour in many respects.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.