Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I would like to stop my network card from using the Minstrel algorithm because of a problem I am having.

I have tried creating /etc/modprobe.d/80211.conf with the following in it:

options mac80211
ieee80211_default_rc_algo=pid

But that doesn't seem to work.

Any ideas?

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted
+100

You must put the whole thing on one line:

options mac80211 ieee80211_default_rc_algo=pid

And then reboot.

Confirm the parameter has taken effect:

cat /sys/modules/mac80211/parameters/ieee80211_default_rc_algo

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.