Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I attach my external hard drive, I cannot access it, because permissions are granted not to me but to another user.

I'm using Ubuntu 10.10, Maverick Meerkat.

  1. Where do I report this as a bug? 1b. Is it a Ubuntu, or a Nautilus, or a Gnome problem?

  2. Is there a solution for this problem?

Any help will be appreciated!

share|improve this question
    
How did you mount your drive? Through Nautilus? –  Lekensteyn Mar 13 '11 at 21:13
    
Post the relevant parts of your /etc/fstab and of sudo mount. –  Apalala Mar 13 '11 at 21:14
    
@Apalala: mount without arguments does not need to be executed as root. –  Lekensteyn Mar 13 '11 at 21:22
    
Have you tried chown or chmod in a terminal –  Mark Rooney Mar 13 '11 at 23:07
add comment

1 Answer

up vote 4 down vote accepted

It isn't a bug. Either you have added an incorrect entry to your /etc/fstab, or you are mounting a filesystem that stores permissions and was created on another machine, and so the ownership information is not correct on yours. If the former, then you need to chown the files to fix it, but this will of course, cause the same problem if you take the drive back to the other machine.

If you plan on moving the drive back and forth between machines, then you should use fat or ntfs. UDF is also an option if you don't mind incompatibility with Windows since it refuses to mount a UDF filesystem on anything but optical media.

share|improve this answer
    
Psusi, thanks for your very clear answer. I'll look into /etc/fstab and will also inspect the filestystem and make sure it is using fat. Thanks! –  Wim Feijen Mar 15 '11 at 9:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.