Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Problem: Improper Drawing in Some Windows

OS: Ubuntu 12.04 (Mythbuntu)

Motherboard: ASUS M5A88-V Evo with integrated Radeon HD4250 graphics card.

$ lspci -nn | grep VGA
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RS880 [Radeon HD 4250] [1002:9715]
06:08.0 Non-VGA unclassified device [0000]: Device [1b7c:0004] (rev 01)

After screwing up my video driver installation as detailed here, I was able to reinstall the desktop, get my GUI back, and finally successfully installed the proprietary Catalyst 13.1 drivers. However, that didn't fix my problem.

I'm having the same drawing issues that I was having without the proprietary drivers.

Most windows draw fine, but Chromium gives me blank pages, MythTV doesn't draw properly, and even the Catalyst Control Center doesn't draw properly, as is shown in the following image:

Bad Drawing

I have x11vnc installed, and I see the same thing remotely and locally. I have tried disabling x11vnc, but that didn't fix the problem. But could there still be some connection?

Any ideas on what's wrong and how to fix this?? Thanks!


When I run Catalyst from the command line, I receive these errors. Methinks this is telling, if only I knew what it meant...

$ gksudo amdcccle
(gksudo:3666): Gdk-WARNING **: shmget failed: error 28 (No space left on device)
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x0
X Error: BadDrawable (invalid Pixmap or Window parameter) 9
  Major opcode: 62 (X_CopyArea)
  Resource id:  0x0
share|improve this question
What about a reinstall? –  LnxSlck May 30 '13 at 22:09
Of the whole OS, you mean, or the driver? I just installed the driver, and it's the same before and after. I haven't tried a complete OS install, yet. But this problem was there before I started fiddling with the display drivers. I can't say whether or not the problem was there after the fresh install, but if it wasn't, I don't have any clue what broke it. I will try a fresh install later, though, and see how it looks. –  tfjield May 30 '13 at 22:28
OK, it turns out that x11vnc WAS the culprit after all! The clue was the shget error shown above. When I looked to see the shared memory handles, I saw a lot of handles to a few processes, over and over. When I looked up the processes, it turned out to be x11vnc! I'm using the popular x11vnc.conf found on the net to get it to start, but I had added a respawn, just in case. For whatever reason, it was spawning over and over, even though it wasn't crashing, and I had 100 instances running, each using multiple shared memory handles. Removing the respawn fixed it. –  tfjield May 31 '13 at 0:45
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.