Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Short description

Being able to use my BT headset with A2DP, I'm unable to switch it to HSP/HFP to use the microphone which I need to e.g. make Skype calls. As soon as I switch it with Blueman, pavucontrol, or even pactl, the device disappears entirely until I switch it off and on again (and then very fast switch its profile back to A2DP before it tries to reconnect). [Using a different bluetooth dongle (see "Update 2" below) this does no longer happen -- but still the microphone doesn't turn up in pavucontrol as input.] As this happens with two different headset devices, it seems to be Ubuntu's (12.04 here) fault (bug in bluez or in pulseaudio). Any idea how to fix that? I already searched all questions on "bluetooth+headset" here, and google'd for days now.

TL;DR

Tired of being cable-bound to my computer (running Ubuntu 12.04), I just got myself a bluetooth headset (deleyCON). After struggling half a day to get it connected at all, I finally suceeded with that using Blueman. Sound is fine, but the microphone doesn't play along -- a no-go for me, as I also wanted to use it for Skype calls.

Connected via A2DP, it turns up fine in pavucontrol as well as being shown connected and all with Blueman. But as soon as I try to switch it to HSP, trouble starts: doing so in pavucontrol makes the device disappearing immediately, and never coming back. Trying with Blueman results in the same concerning pavucontrol, and just lists the device unavailable in Blueman. I have to switch off the headset, switch it on again and being fast enough to connect in with Blueman using A2DP before it disappears (I guess switching the mode before it has fully connected does the trick here, as otherwise it would try the last connected mode).

Thinking it might be the headset's fault, I charged up my old Sony HBH-610a bluetooth headset (mono, intended for telephony). This does not seem to support A2DP and, accordingly, is unusable on my computer: it pairs fine, but never turns up in pavucontrol; Blueman fails to connect it using HSP/HFP.

I went the questions up and down here (using this search), checked everything which seemed even remotely connected to my issue. Even following up to Bug #972063 at Launchpad, and trying some of the proposed work-arounds (like inserting Enable=Source,Sink,Headset,Gateway,Control,Socket,Media to the [General] section of /etc/bluetooth/audio.conf) didn't solve it.

Now I'm stuck without any clue. As both headsets seem to fail with HSP, it looks like it's Ubuntu's fault (otherwise I had returned the headset for a different one). I still have a few days left to return it -- if anybody can tell me it's the device and not the system. Is there anything I could try to get it working? Or are the two headsets mentioned known to be incompatible, while others do work?

Update:

Now, after a reboot (and switching from KDE to LXDE), mixed results. Good news: I can not only switch profiles, but even have them enabled simultaneously in Blueman (HFP and A2DP). Bad news: nothing turns up in pavucontrol, even after manually loading pactl load-module module-bluetooth-discover. Loading module-bluetooth-device fails to initialize the module (that was the same in KDE). In /var/log/syslog I see:

pulseaudio[2250]: [bluetooth] module-bluetooth-device.c: Failed to write data to SCO socket: invalid argument
bluetoothd[7978]: Badly formated or unrecognized command: AT+CSRSF=0,0,0,0,0,7

Disconnecting and re-connecting the headset suddenly makes two entries visible in pavucontrol (one with a headset symbol and disabled, one with a bluetooth symbol and set to A2DP), so I already started to rejoice -- but too early: As soon as I switch one of the two entries to HSP/HFP, it disappears from pavucontrol (syslog: bluetoothd[7978]: Audio connection got disconnected, while Blueman still shows both profiles connected) until I disconnect and reconnect the headset. So the only improvement so far is that I can now connect both profiles using Blueman. But now Skype does not even use the headset for output: pavucontrol shows this goes to the internal soundcard :( Playing sound from other sources (I tried with mp3blaster) goes to the headset fine -- which brings up the question where those defaults are handled (and where I can fix that)...

Update 2:

Switching to a different (no-name) Bluetooth adapter, I can now successfully switch to HSP/HFP in pavucontrol. However, the microphon does not show up in input controls, so I still cannot use the headset for HSP/HFP, e.g. for Skype calls. [Trying the second headset, situation for that one is still unchanged: pairing successfull, but not usable at all.] Is there anybody out there having used this specific headset successfully including its microphon? Or is the remaining problem rather specific to this headset (as the first part was specific to the adapter used)? Unfortunately, I don't have so many headsets here to check :)

share|improve this question
    
OK, so it's not Ubuntu per se -- and some hope to get it fixed. Here runs amd64 as well, Dongle is AVM GmbH BlueFRITZ! Bluetooth Stick. Could the stick be the culprit -- and if so, how to check? Plus: you write H2DP. Only profiles I get displayed are A2DP and HSP/HFP. Where do you see H2DP, and how do you switch "on the fly"? –  Izzy May 31 '13 at 7:00
    
Oh well, it might make my BT headset disappear automatically -- bur right, that's not what I'm after :D Trouble is, I've checked with all sources I could find. I don't see that any software package is missing. I don't see any configuration step I didn't try. Maybe there's something in /etc/bluetooth/* which I could try, but I don't know what. Checking my /var/log/syslog, the only possibly relevant thing I can see is Badly formated or unrecognized command: AT+CSRSF=0,0,0,0,0,7 –  Izzy May 31 '13 at 7:34
    
I did that, and the headset disappeared completely from pavucontrol. To re-connect it at all I had to switch it off, then on and very fast switch it to A2DP using Blueman. But I will try again while watching for all output in /var/log/syslog. Still, that wouldn't explain why the other headset did not show up again (here the problem might be that there was already one headset connected when I tried). Thanks for the suggestion, will try when I'm back home. –  Izzy May 31 '13 at 8:12
    
@Takkat I just updated my question with the latest happenings. Now I can switch profiles fine in Blueman, even load them simultaneously -- but unfortunately still have the same situation in pavucontrol: I cannot use HSP/HFP for input :( –  Izzy May 31 '13 at 22:10
    
@Takkat I already have Enable=Source,Sink,Headset,Gateway,Control,Socket,Media there (see original question), which includes "Socket" (if I remember correctly, I've picket that idea from the bug linked there). As with Stefan over there, it didn't help in my case. I could not figure out what chipset my adapter (AVM GmbH BlueFRITZ! Bluetooth Stick, see above) is using: neither dmesg, any documentation from the manufacturer, or googling turned up something :( –  Izzy Jun 1 '13 at 14:31
show 3 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.