Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am getting this error when attempting to load a Desktop module up within Citrix Receiver:

enter image description here

What I don't understand is I can see this particular certificate is set to "Trust.." under any/all circumstances that I can find. This only happens in Ubuntu, and I did not installed any certificates (manually) on either partition when trying to correct the issue. The browser also appears to be irrelevant (Chrome/Firefox both generate the same error). Forgive my ignorance on certificates, but this seems to be beyond my expertise.

There are a few places I've looked through various search engines, and I found other users who have had similar issues with certificates in the Linux Citrix Receiver, but I'm not sure what's wrong with this certificate, as none of the other suggestions I've tried have worked so far, and they're too numerous to go into detail... so I'd like to take it from here and see what you all can offer up.

share|improve this question

3 Answers 3

up vote 1 down vote accepted

To prevent the SSL error 61 when accessing remote sessions:

Make Firefox's certificates accessible to Citrix,

sudo ln -s /usr/share/ca-certificates/mozilla/* /opt/Citrix/ICAClient/keystore/cacerts

Source: Citrix help page

share|improve this answer
    
Worked like a charm. Don't know how I missed this on Citrix's own site, I guess I was looking too much at user-centric help/forums. –  gravity May 31 '13 at 13:03

some users (like me) might find that even after linking Firefox to the cacerts folder the error persists.

That appears to be because Citrix does not supply all of the latest certificates.

The solution appears to be to note the certificate said to be "not trusted" (eg "Verisign Class 3 Public Primary Certification Authority - G5") then export it from Firefox (under the Preferences menu then Certificates) to */ICAClient/keystore/cacerts.

Worked for me. Hope this helps.

share|improve this answer
    
so close yet so far! No joy for me I'm afraid –  LRE Jun 10 at 21:22

I tried the solution above but did not work for me see this http://crazymadeagle.blogspot.com/2013/07/howto-install-citrix-client-on-ubuntu.html it might help

share|improve this answer
1  
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  guntbert Jul 11 '13 at 16:45

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.