Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I cannot run an executable file, and it seems that all permissions, owner, etc. are correct. I don't understand the problem; I hope that someone will find a solution.

I'm logged as tux.

tux@tux-laptop:~/Data/Flightplan/FPP0.19Linux$ whoami
tux

Here is the directory where the executable resides. The file that I'm trying to run is FP (the program is installed and owned by tux, FP is Flightplanpro for Linux)

tux@tux-laptop:~/Data/Flightplan/FPP0.19Linux$ ls -l
total 113588
-rwxr-xr-x 1 tux tux 23807760 2013-05-30 19:26 FP

When I try to run FP, this happens:

tux@tux-laptop:~/Data/Flightplan/FPP0.19Linux$ ./FP
bash: ./FP: Permission denied

I checked 100 times and I made sure that the flag "Allow executing file as program" is ON. Using sudo or root doesn't help; the permission denied error doesn't show up, but nothing happens.

tux@tux-laptop:~/Data/Flightplan/FPP0.19Linux$ sudo ./FP

I can run that program on my other Linux machine without any problem.

I'm running Ubuntu 11.10 (for various reasons including disc space, I cannot upgrade).

share|improve this question
    
Have you made the file FP executable? sudo chmod +x FP –  SimplySimon May 30 '13 at 20:50
    
Are there other files that it might need to successfully execute? They may be present but lack the permission. Maybe try setting permissions recursively with the -R command on the directory to make sure it isn't something funny like that. –  brim4brim May 30 '13 at 21:05
1  
If you trying to run this from an USB stick, chances are that it is mounted 'noexec,nodev'. Remount it 'defaults,rw' and it will work. –  aquaherd May 30 '13 at 21:52
    
Thkx for your help ! @Simplysimon; tried the chmod but same thing @brim4brim,this is the only prog to run, no sub prog are called. The program is on the drive not on USB stick or disc. I already faced the same issue (with no solution) with progs installed without ubuntu software center. I compared file permissions and properties with the one on the other working computer and everything is absolutely the same for what file and directory are concerned. Is there somewhere any global security setting in Ubuntu ? Thkx again ! –  Did.vdt May 30 '13 at 22:27
    
Are you experiencing this issue still? –  Braiam Sep 17 '13 at 23:43
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.