Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Ubuntu PC used as a file server running 12.10 64bit. I am able to connect to it using Linux Mint, Windows7 and Windows 8, but unable to connect using Ubuntu 13.04.

I have tried creating a link on the 13.04 Desktop, but the 'create launcher' feature has been removed from the right click menu, so tried via terminal to create the link:

gnome-desktop-item-edit ~/Desktop/ --create-new

however, clicking on the launcher just times out.

Tried to connect through Dolphin, the same problem, connection times out.

If I explore the local network going to location smb:/// the connection times out.

If I try to go direct to a share folder smb://192.168.0.2/Videos again times out

share|improve this question
1  
Have the same problem as you.. I use Ubuntu 12.04 LTS on my HTPC and have set-up a share, can access it from anywhere but not my laptop, Ubuntu 12.10. Can connect from win7, win8 and Android.. Why so difficult? Have to use FTP or SSH to transfer files and then move it to the correct folder on the HTPC.. –  aXept May 30 '13 at 20:29
    
Can you connect to it with smbclient? Something like smbclient \\\\zimmerman\\public mypasswd or with -Uusername if it is shared for a specific username. You should also install cifs-utils to be able to mount them –  labsin May 30 '13 at 20:44
    
Thanks. I was always able to connect in Nautilus just using either smb:/// and browsing the network or direct to a drive using smb://192.168.0.2/Videos So what has changed I wonder? I can still connect using a Linux Mint laptop, which is based on an earlier version of Ubuntu, I believe 12.04LTS, however Mint is tweaked so only vaguely resembles Ubuntu. I may try a downgrade to Nautilus to 3.4 or the SolusOS Nautilus Patch.... Thanks again –  pst007x May 30 '13 at 21:14

1 Answer 1

up vote 1 down vote accepted

I found this info and it resolved my issue:

We will need to edit the smb.conf and the nsswitch.conf:

  • add the name of your network example: MSHOME or WORKGROUP ,etc
  • we will add your computer name, in my case: pst007x-Serval-Professional
  • change name resolve order
  • edit the HOSTS in the nsswitch.conf

RUN in Terminal:

sudo gedit /etc/samba/smb.conf

EDIT THE smb.conf FILE, add the workgroup and netbios name:

[global]

## Browsing/Identification ##

# Change this to the workgroup/NT-domain name your Samba server will part of

workgroup = WORKGROUP

netbios name = pst007x-Serval-Professional

NOW FIND:

;        name resolve order = lmhosts host wins bcast

CHANGE THIS LINE TO:

         name resolve order = lmhosts wins bcast host

SAVE AND EXIT

NOW ONE MORE FILE TO EDIT:

sudo gedit /etc/nsswitch.conf

CHANGE THE FOLLOWING LINE:

hosts: files myhostname mdns4_minimal [NOTFOUND=return] dns mdns4

TO:

hosts: files myhostname mdns4_minimal [NOTFOUND=return] wins dns mdns4

NOW RESTART SYSTEM

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.