Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I recently updated to ubuntu 13.04, after installing some random program from the software-center I get the "Package operation failed"- "The installation or removal of a software package failed." and it looks like it has to do with python 3.3. Can someone explain what is this all about.(note that the random program was installed)

full paste

installArchives() failed: Selecting previously unselected package zenmap.
(Reading database ... 
(Reading database ... 5%
(Reading database ... 10%
(Reading database ... 15%
(Reading database ... 20%

----------

Unpacking zenmap (from .../zenmap_6.00-0.3_i386.deb) ...
Processing triggers for man-db ...
Processing triggers for desktop-file-utils ...
Setting up python3.3-minimal (3.3.1-1ubuntu5) ...
Traceback (most recent call last):
  File "/usr/lib/python3.3/py_compile.py", line 8, in <module>
    import imp
  File "/usr/lib/python3.3/imp.py", line 28, in <module>
    import tokenize
  File "/usr/lib/python3.3/tokenize.py", line 28, in <module>
    import re
  File "/usr/lib/python3.3/re.py", line 122, in <module>
    import sre_compile
  File "/usr/lib/python3.3/sre_compile.py", line 14, in <module>
    import sre_parse
  File "/usr/lib/python3.3/sre_parse.py", line 17, in <module>
    from sre_constants import *
  File "/usr/lib/python3.3/sre_constants.py", line 18, in <module>
    from _sre import MAXREPEAT
ImportError: cannot import name MAXREPEAT
dpkg: error processing python3.3-minimal (--configure):
 subprocess installed post-installation script returned error exit status 1
No apport report written because MaxReports is reached already
dpkg: dependency problems prevent configuration of python3-minimal:
 python3-minimal depends on python3.3-minimal (>= 3.3.1-1~); however:
  Package python3.3-minimal is not configured yet.

dpkg: error processing python3-minimal (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3.3:
 python3.3 depends on python3.3-minimal (= 3.3.1-1ubuntu5); however:
  Package python3.3-minimal is not configured yet.

dpkg: error processing python3.3 (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of python3:
 python3 depends on python3.3 (>= 3.3.1-1~); however:
  Package python3.3 is not configured yet.
 python3 depends on python3-minimal (= 3.3.1-0ubuntu1); however:
  Package python3-minimal is not configured yet.
----------
Errors were encountered while processing:
 python3.3-minimal
 python3-minimal
 python3.3
 python3
 python3-apt
 python3-dbus
 language-selector-common
 python3-gi
 bluez
 gnome-menus
 kde-runtime
 kdenlive
 gnome-bluetooth
 indicator-bluetooth
 gnome-control-center
 python3-xkit
 ubuntu-drivers-common
 python3-pkg-resources
 python3-crypto
 python3-oauthlib
 friends-dispatcher
 libfriends0
 lsb-release
 ubuntu-minimal
 python3-gdbm:i386
 python3-commandnotfound
 command-not-found
 python3-distupgrade
 python3-update-manager
 ubuntu-release-upgrader-core
 ubuntu-standard
 ufw
 update-manager-core
 python3-problem-report
 python3-apport
 apport
 apport-gtk
 apturl-common
 unattended-upgrades
 python3-software-properties
 software-properties-common
 python3-aptdaemon
 python3-aptdaemon.gtk3widgets
 software-properties-gtk
 apturl
Setting up zenmap (6.00-0.3) ...
Setting up python3.3-minimal (3.3.1-1ubuntu5) ...
Traceback (most recent call last):
share|improve this question

marked as duplicate by hbdgaf, Luis Alvarado Aug 4 at 18:58

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
same problem [here][1]: solved by Gx1sptDTDa [1]: askubuntu.com/questions/316189/… –  bigTree Jul 4 '13 at 12:42

2 Answers 2

If you have Synaptic Package Manager installed open it, then select "broken" on the left side. Uninstall or reinstall the broken package.

I was showing libmotif4 as a broken package. Turned out I had libmotif3 installed as well and this was causing an issue. I removed libmotif3 and reinstalled 4.

share|improve this answer
    
Maybe in "Fix broken packages" from the menu.. –  ring0 Jul 5 at 9:35

open your terminal and type as

sudo apt-get update
sudo dpkg-reconfigure -a
share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.